ArcanumBanette Jul 27 @ 4:52pm
Afterglow troubleshooting issue
Laptop: A Lenovo G500

OS: Windows 8

Controller: an Afterglow wired one (360 style)

Issue: I plug the controller into a USB slot. It blinks blue for a second, and then stops. The computer doesn't even recoginve that something is plugged into the USB. AKA: Not noticing the cotroller exists, anything is in the USB port, no troubleshooting is pulling up on my computer-as if their is no controller there.

What I have tried:
1) A different USB port, same result. It's not my USB ports. Everything else works fine in them, my mouse, chargers....
2) Trying the controller on a friends laptop. It works fine. Installs and everything.
3) I have tried rebooting the computer, with the controller still plugged in. It flashes blue when the laptop first starts to turn on, then flashes blue again once I get onto the desktop page, then back to the same result as before.
4) I have tried manually installing drivers for Windows 7 64-bit. From what I researched that was a common fix to the controller not working in game. The computer says I already have it installed. I have deleted the same file time and time again, and made sure to clear it from my recycle bin, but everytime it says I already have it installed, even after I restart the system. I have tried the 32-bit as well, just to try it. Same results. I have run thn the 64-bit in compataibly mode as well, same thing. Is there a spot where the file could be hiding?

I am not terribly bright with techonology and I am only trying what I can that looks safe and sounds like it works. Please help me out guys. I am at my ropes end. I will continue to try and fix the problem, and if I find a fix I will post it here if anyone else has this same problem. Until then, any suggestion would be grateful, thank you.
Showing 1-4 of 4 comments
< >
Breeze Block Jul 31 @ 9:58am 
Same issue mate, at first i thought it was my pad as its taken some abuse over the last 3 years so i went and bought another, followed the same steps as you, even as most threads tell me to go and get the drivers from the microshite site which doesnt bloody work, has any1 come across a hard fix or work around, im quite happy tweaking a 3-rd party software if needs be.....
Spawn of Totoro Jul 31 @ 10:11am 
You have to manually tell Windows what driver to use as it is a 3rd party controller.

You can skip to the drivers part as W8/8.1 already include it. It is the same process for both OSs.

https://www.youtube.com/watch?v=mDKTs8snvg8
Last edited by Spawn of Totoro; Jul 31 @ 10:13am
Breeze Block Jul 31 @ 1:00pm 
Found the solution.
Went directly to the hardware manufacturer of the gamepad and nestled in their support pages was a easy to use step by clear step guide that got my pad working again within 5 mins

http://support.pdp.com/ics/support/default.asp?deptID=5553&redirect=true

Case closed
ArcanumBanette Jul 31 @ 8:43pm 
None of these worked. My computer is not picking up anything is plugged in, at all. I can't update the driver manually for something the computer does not realize is plugged in.

Once again, it is not the USB ports. I have tried different USB ports, same result. I have switced the USB port the adaptor for my wireless mouse is in to check this, and the mouse worked fine no matter where the USB adaptor was.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Jul 27 @ 4:52pm
Posts: 4