SilverwingsLTD Nov 21, 2012 @ 10:41pm
Assassins Creed 3, cant login to UPLAY
Okay, so last night, when AC3 came out, i tried to log in to the uplay program thingy to confirm my game, but it keeps saying there is something wrong with my internet connection. Does someone know when this will be fixed? Or if anyone has a fix it would be appreciated. Thank you for your time in advance!
I'd also like to add, i tried this morning and it still doesnt work.
Last edited by SilverwingsLTD; Nov 21, 2012 @ 10:43pm
Showing 1-14 of 14 comments
< >
BeardedVillain Nov 21, 2012 @ 10:47pm 
I just logged into uplay and it works fine for me. Have you tried reinstalling uplay? Or perhaps your router or anti-virus is blocking it from your network...
SilverwingsLTD Nov 21, 2012 @ 10:53pm 
Originally posted by BeardedVillain:
I just logged into uplay and it works fine for me. Have you tried reinstalling uplay? Or perhaps your router or anti-virus is blocking it from your network...
I'll try that, if my router is blocking uplay, should i restart it?
SilverwingsLTD Nov 21, 2012 @ 10:56pm 
ffs i tried to delete uplay, and when i wanted to reinstall it again on the site, i just get a f'n error.
BeardedVillain Nov 21, 2012 @ 11:00pm 
I googled your issue and came up with this from a ubisoft manager: http://ubisoft.custhelp.com/app/answers/detail/a_id/16662/p/0

Try each of those steps to see if it resolves your issue.
SilverwingsLTD Nov 21, 2012 @ 11:15pm 
Great, now i cant even enter UPLAY because its impossible to f'n download again! So now i have to reinstall the game, and that took several ♥♥♥♥ing long hours and i am so ♥♥♥♥ed right now that ubisoft cant make anything ♥♥♥♥ing work! ♥♥♥♥ you Ubisoft and your stupid ♥♥♥♥ing launcher!
~Petkip Nov 22, 2012 @ 7:54am 
in your ac3 instal there is a map suport there you can find a uplay installer, had the same problem that I cant download it, but still it wont connect to the internet ffs D: I WANT AC3 NOW
Gam3r0wn3d Nov 23, 2012 @ 4:21pm 
Configure your firewall or router to allow uplay access to the internet
TeQuiiLaSHoTZz Nov 24, 2012 @ 2:32am 
i unpicked a proxy checkbox and it worked
Champy Nov 25, 2012 @ 12:49am 
Same problems here. I cannot do anything for it. My friend can log in with my account on his pc, so the problem is at me, and I can log in in my browser, so the problem is with the program. I tried to reinstall, i deleted all my previous ubisoft games, but it still says i cant log in.
Champy Nov 25, 2012 @ 1:43am 
OH YEAH I MADE IT!
the final solution is: delete your hosts file from C:\Windows\System32\drivers\etc.C:\Windows\System32\drivers\etc., or wherever it is.
It now works for me :)
Rezet Nov 25, 2012 @ 12:36pm 
Hi may iask what finally helped you? Because i have the same problem( f.... uplay!) Thx
Prospanker Nov 26, 2012 @ 5:08am 
Originally posted by Champy:
OH YEAH I MADE IT!
the final solution is: delete your hosts file from C:\Windows\System32\drivers\etc.C:\Windows\System32\drivers\etc., or wherever it is.
It now works for me :)
Champy! Thank you for your suggestion, it really works!
Heffebaycay Nov 26, 2012 @ 6:42am 
Originally posted by Champy:
OH YEAH I MADE IT!
the final solution is: delete your hosts file from C:\Windows\System32\drivers\etc.C:\Windows\System32\drivers\etc., or wherever it is.
It now works for me :)
Unless you tried to pirate a Uplay game, there shouldn't be any reference to Uplay servers in your Windows host file...
Terrai Hado Nov 29, 2012 @ 3:47am 
Originally posted by Champy:
OH YEAH I MADE IT!
the final solution is: delete your hosts file from C:\Windows\System32\drivers\etc.C:\Windows\System32\drivers\etc., or wherever it is.
It now works for me :)
did this and it worked fine!! Thanks man!!!!!
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Nov 21, 2012 @ 10:41pm
Posts: 14