Blazin23 Jul 26, 2013 @ 2:41am
Deus Ex Human Revolution - Can't start or play game
Hello guys, I've read countless threads about Deus Ex HR not being able to start (it just creates a dump file, steam thinks I'm playing it for a second then goes back to normal) and have not seen or found a single working fix. I am running Windows 8 with an Intel i5 4670K and Nvidia GeForce GTX 780 3GB.

I have:
- Checked integrity of game cache
- Deleted steam.api and a few other files, re-downloaded and checked integrity
- Updated to latest Nvidia driver, and then tried latest beta driver - neither worked
- Updated Java
- Updated Flash
- Ran as administrator
- Ran in all the compatibility modes
- Updated Visual C++
- Already have latest .Net

I also checked for the ati dll file bug I saw, but as that mostly occurred when people moved from an ati to nvidia graphics card, it is unlikely for me as my PC is only a couple weeks old (and I could not even find the ati files to rename)

So does anyone have any other suggestions? I take it I have no grounds for a refund here as the game does not officially support Windows 8, and I don't particularly want to start a help call with Steam or Eidos just to wait weeks for an automated response.

I cannot load the game, or the set up (to change graphical settings etc) but the Missing Link DLC loads fine.

Thanks in advance
Last edited by Blazin23; Jul 26, 2013 @ 2:53am
Date Posted: Jul 26, 2013 @ 2:41am
Posts: 0