Dado Feb 18, 2013 @ 12:49pm
Steam is Updating constantly
I have the Steam - Self Updater starting up constantly
I am not nonparticipating in any betas.
the update is dated;

February 15, 2013 - Steam Client Update Released
Changes:
- Fixed texture corruption when using the Game Overlay in OpenGL games
- Fixed failing to do HTTP downloads from hosts that started with a numeral
- Linux - Added X window manager name to system info dialog
Showing 1-13 of 13 comments
< >
mudkipz Feb 18, 2013 @ 1:37pm 
I have the same problem. Every time I start steam it runs the updater even though it's already up to date.
carol Feb 18, 2013 @ 5:07pm 
Same here - anyway to stop this. Really annoying!
PsychoLandlord Feb 18, 2013 @ 5:47pm 
I had this problem, and did a quick refresh of Steam by deleting everything but the Steam.exe, steamapps, and userdata, then running the .exe and letting it reacquire everything. Problem is, now I've been hit with the bug where your taskbar icon stays green/yellow despite there being no game or tool downloads occuring. So be wary of that.
wulfsiege Feb 18, 2013 @ 6:19pm 
I am having the same problem as well. Updater runs on every start, not participating in the Steam Beta.
Satoru Feb 18, 2013 @ 6:52pm 
Ensure you're running steam as an admin
Darth Feeder Feb 20, 2013 @ 10:36pm 
I'm having the same problem, running as admin doesn't fix it.

Steam sometimes asks me to restart when running the background, and it's always because of the same update (February 15, same as OP).

I never had a problem like this before.
Darth Feeder Feb 23, 2013 @ 2:03am 
Anyone got it fixed yet?
gargamell999 Feb 23, 2013 @ 5:31am 
I have the steam update when i first boot up the computer, after windows is all done. after that minor steam update, it gose away.
wulfsiege Feb 23, 2013 @ 7:53am 
The problem has fixed itself for me.
Darth Feeder Mar 3, 2013 @ 10:36pm 
It's finally fixed. The last things I did were:

- Properties > Compatibility > "Change settings for all users" > Run as admin.
- Set to participate in Steam beta, then change it back after a few days.

Other options I tried before did not fix it. Like deleting ClientRegistry.blob, and updating Windows, or run as admin for only one user.

Steam support told me to delete everything but the Steam.exe, Userdata and SteamApps, which were around 2GB that I had to redownload. None of that was needed.
wulfsiege Mar 4, 2013 @ 6:26am 
The problem as also re-occured for me after going away for a short while. Im a Win 7 64 bit. I will just wait for a patch instead of messing around and wasting my time on it.
◣◢)┌∩┐ DiCe-Azzu Jun 7, 2013 @ 12:06am 
Originally posted by py00q:
It's finally fixed. The last things I did were:

- Properties > Compatibility > "Change settings for all users" > Run as admin.
- Set to participate in Steam beta, then change it back after a few days.

Other options I tried before did not fix it. Like deleting ClientRegistry.blob, and updating Windows, or run as admin for only one user.

Steam support told me to delete everything but the Steam.exe, Userdata and SteamApps, which were around 2GB that I had to redownload. None of that was needed.

This works, it has worked for myself and a few friends :) Thanks so much :)
carol Jun 8, 2013 @ 5:58am 
Actuall I found that just subscribing to beta releases and allowing steam to restart fixed the issue. Obviously fixed in the upcoming release when it goes out of beta.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Feb 18, 2013 @ 12:49pm
Posts: 13