The Mad Orange May 30, 2013 @ 4:23pm
"Could not connect to Steam network." However, no solutions have worked!
After installing TF2 and opening it for the first time, no servers were loading, so I closed the game and restarted Steam. After this, I was unable to log in at all. I get the "Could not connect to Steam network. This could be due to a problem with your internet..." message. I have tried the following to fix this:

- Deleting clientregistry.blob
- Deleting registry.vdf
- Deleting everything in the Steam folder with the exception of SteamApps
- Deleting everything entirely, including the executable and the SteamApps folder (now lost all of my game saves as I thought TF2 may have corrupted my install)
- Logging into Steam from the web browser and then running the client
- Running steam from terminal (./steam.sh).
- Repairing the disk permissions on my Mac partition.
- Getting my friend to log in with his account (still doesn't work)
- Using the incorrect password on purpose (no difference)

When running steam.sh from the terminal, this is the output when I attempt to log in:

[2013-05-31 00:17:12] Startup - updater built May 3 2013 15:11:18
found breakpad via in process memory: '/Applications/Steam.app/Contents/MacOS/Frameworks/Breakpad.framework/Versions/A/Resources'
Installing breakpad crash handler
SteamID: 0, universe Public
[2013-05-31 00:17:12] Verifying installation...
[2013-05-31 00:17:12] Verification complete
SteamID: 0, universe Public
unlinked 0 orphaned pipes
$$$: Status -10811
SteamID: 0, universe Public
SteamID: 0, universe Public
SteamID: 0, universe Public
SteamID: 0, universe Public
SteamID: 0, universe Public
SteamID: 0, universe Public
SteamID: 76561197960265728, universe Public
SteamID: 76561197960265728, universe Public
/Users/buildbot/buildslave_steam/steam_rel_client_osx/build/src/clientdll/user.cpp (5069) : Assertion Failed: Calling GetUserConfigFolder before we know our SteamID
Assert( Assertion Failed: Calling GetUserConfigFolder before we know our SteamID ):/Users/buildbot/buildslave_steam/steam_rel_client_osx/build/src/clientdll/user.cpp:5069

SteamID: 76561197960265728, universe Public
local (potentially out of sync) copy of roaming config loaded - 0 bytes.
/Users/buildbot/buildslave_steam/steam_rel_client_osx/build/src/steamUI/SteamDoc.cpp (2936) : Assertion Failed: CSteamDoc::InitializeUserConfigDir: failed to get config folder for [U:1:0]



I am running Mac 10.8 Mountain Lion.

Hope I can get a solution soon.
Showing 1-15 of 61 comments
< >
The Mad Orange Jun 2, 2013 @ 3:40pm 
Has no-one else ever had this problem? I have been searching the internet for 3 days now. And Valve aren't replying, either. I'm currently relying on help from this forum because I'm giving up deleting/reinstalling Steam and its associated files...
Helelix Jun 2, 2013 @ 10:30pm 
Yeah, I've had this problem for quite some time now, although I'm using Windows 7. I seem to have narrowed it down to my PC not being able to connect to the Steam Network but I can't figure out why it wont connect. The correct ports that Steam uses are forwarded and I can't find any reason why my computer is blocking the Steam traffic (although I'm unsure if its blocking traffic too Steam, or from Steam or both).

Have you tried reinstalling steam completely using the installer from http://store.steampowered.com/about/ ? With me it downloads and installs fine but when run, it will search for updates (to complete the install) but fail stating that "I must be connected to the Internet".

Anyway, I hope you or someone else finds a solution soon, because I've pretty much run out of ideas.
Larrikin Jun 2, 2013 @ 10:35pm 
I had this problem and reinstalling seemed to do the trick in fixing it
Helelix Jun 2, 2013 @ 10:37pm 
heh. If you actually read our comments you'll see that we tried that ;)
Helena Jul 5, 2013 @ 4:53pm 
Oh thank god it's not just me.

On Ubuntu 12.10, I've tried:

- Wiping ~/.steam ~/Steam ~/.local/share/Steam
- apt-get purge steam
- rm /usr/bin/steam
- Reinstalling from the latest .deb

I've tried on several network where I've never had a problem before, and with my firewall disabled the whole time.

Installing breakpad exception handler for appid(steam)/version(1370553818_client)
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/assert_20130705184237_1.dmp
local (potentially out of sync) copy of roaming config loaded - 0 bytes.
/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/steamUI/SteamDoc.cpp (2957) : Assertion Failed: CSteamDoc::InitializeUserConfigDir: failed to get config folder for [U:1:0]
Finished uploading minidump (out-of-process): success = no
error: HTTP response code said error
System startup time: 64.39 seconds
Generating new string page texture 29: 512x256, total string texture memory is 1.51 MB
Running Steam on ubuntu 12.10 64-bit
STEAM_RUNTIME has been set by the user to: /home/hxr/.local/share/Steam/ubuntu12_32/steam-runtime
unlinked 2 orphaned pipes
CAsyncIOManager: 0 threads terminating. 0 reads, 0 writes, 0 deferrals.
CAsyncIOManager: 11347 single object sleeps, 0 multi object sleeps
CAsyncIOManager: 0 single object alertable sleeps, 2 multi object alertable sleeps
[2013-07-05 18:41:32] Startup - updater built Jun 6 2013 13:48:29
[2013-07-05 18:41:32] Verifying installation...
[2013-07-05 18:41:32] Verification complete
Shutting down. . .
[2013-07-05 18:42:40] Shutdown

wiresharking the output, I don't think they're even getting these reports. I'm seeing a HTTP/1.1 500 Internal Server Error response from everything that's getting sent to crash.steampowered.com
Alois Jul 5, 2013 @ 5:18pm 
Ya it isn't just ya'll, I don't know what to do Sent complaints with nothing, I'm having the issue where it appears, if say, you attempt to download, or if say there is an automatic game update you may not be noticing, it'll seem to make your computer to appear to loose your entire connection. But if you pause the update, or delete whatever your trying to download it'll work, updates/downloads will only work fora few seconds at a time, Look to see if your games or something is trying to update, thats only fix atm. Tried reinstall not on our side it's on valve's side.
Alois Jul 5, 2013 @ 5:20pm 
If you reinstalled, maybe trying to delete the games that you most recently installed may do the trick, don't just reinstall steam while trying to save the game app data and all they gota go too not just the app. But you still may not be able to download/play the games.
Last edited by Alois; Jul 5, 2013 @ 5:20pm
Helelix Jul 5, 2013 @ 11:08pm 
Me and another user (TheWackyCheese) over on te Steam forums (seperate from these discussion boards) had a very simmilar problem relating to this. It may not be your problem but this is the thread in which we managed to resolve it: http://forums.steampowered.com/forums/showthread.php?t=3131320

Sadly though, both of us exhaused all of our options nad did a clean install of Windows. I know its not what people want to hear for a problem like this but after a couple months of this problem occuring we decided to take that drastic measure. Anyway, read through that thread and hopefully you can fix your problem.
Cpt.Bouchard Aug 27, 2013 @ 6:59pm 
Could not connect to Steam network [FIX]
This is not official at all. I'm not related to Valve Corp. But I was struggling with that Could not connect to Steam network and I found a way that fix it.

1. Quit Steam
2. Log yourself through a web browser on the Steam website http://store.steampowered.com/.
3. Enter the security code if prompt and login
4. Under Windows, MAC or Linux Open Steam Application
5. Enter your log in credentials
6. Welcome back on Steam!
Last edited by Cpt.Bouchard; Aug 28, 2013 @ 5:45am
tytanium Sep 3, 2013 @ 7:36pm 
"Could not connect to Steam network."
Just wondering why I'm not able to log in to my steam account. I've reinstalled it. Tried what LWFL Bloxwich sugessted. Nothing. Is anyone else having this issue?
m.chinni Sep 26, 2013 @ 3:46pm 
It's not solving my issue.
duckthetruck Sep 26, 2013 @ 3:47pm 
its not really helping
m.chinni Sep 26, 2013 @ 4:13pm 
I solved with a full wipe and reinstall of Steam client (Ubuntu 13.04 64bit).
rangerdanger81 Sep 29, 2013 @ 8:28am 
I'll be damned before I reinstall Windows. I've been down that road before, and there is absolutely no sense in having to waste an entire day like that to play games you already own that won't run because of some crappy 3rd party software.
Lev Sep 29, 2013 @ 8:46am 
had this on osx, reinstalling steam solved the problem... for now
Showing 1-15 of 61 comments
< >
Per page: 15 30 50
Date Posted: May 30, 2013 @ 4:23pm
Posts: 61