Buckaroo Feb 15, 2013 @ 1:35pm
Can't open Steam - Failed update! [Fixed]
The Steam client decided to apply a 19mb patch, and upon extracting and applying I got a "Fatal error". Restarting Steam would cause the exact same problem. So, relunctantly I uninstalled Steam and re-installed it. It ran the 110mb install and extracted, then downloaded and extracted the 19mb patch. However, this time upon the extraction process it just quits and closes Steam altogether with no error. I want to play my steam games! Please HELP!
Last edited by Buckaroo; Feb 15, 2013 @ 5:01pm
< >
Showing 1-5 of 5 comments
banzaigtv Feb 15, 2013 @ 1:38pm 
It's happening to all of us since the latest update. This is the worst disaster that has ever hit Steam. I am now beginning the process of migrating many of my games to Origin. I'm through with Steam.
Buckaroo Feb 15, 2013 @ 2:01pm 
Just saw a thread about deleting the "ClientRegistry.blob" (and another .blob file). This got past the white updating bar downloading the 19mb file, and then gave a "Steam update" bar. Unfortunately, it sat at 0% and after a bit gave the error "Steam is temporarily unavailable, please try later". Have to delete the .blob file again to get to that Steam update (green) bar.

Has Steam/Valve posted anything on this? Any official word on the problem and when it's going to be resolved?
Buckaroo Feb 15, 2013 @ 4:11pm 
Has there been any updates to this issue? Anyone able to get Steam to work yet?
cali_chris286 Feb 15, 2013 @ 4:33pm 
I cant even get to the updating bar.
As soon as I click to open steam I get a fatal error saying "Steam needs to be online to update, but was set to offline mode" Then it just closes. I don't get to see or do anything :/
Buckaroo Feb 15, 2013 @ 4:55pm 
I found a fix... Well, a solution.

I've been having this issue on my laptop all day. I've been at work connected to a fast network--NOT over a WiFi connection, and had the issue. I came home and then tried the same thing on my laptop, but now on my home WiFi network; still had the same problem (even tried a complete re-install).

I went to my actual gaming computer and opened Steam, and it updated just fine without problem! I tried again on my laptop, but it still wouldn't update/install correctly. What gives? The only difference between the two (other than hardware) is the gaming computer is connected via a network cable directly to the router while the laptop is wirelessly connected to the same router. Both computers are running the same OS and version (Win7 Pro 64bit).

Since the gaming computer was up and working, I copied all the install files (minus the "steamapps" folder) from the computer to my laptop and that made Steam work on my laptop once again.

I don't know why one system worked and the other didn't, but this seems to have solved my issue, at least for now. Hope this helps others!
Last edited by Buckaroo; Feb 15, 2013 @ 4:55pm
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Date Posted: Feb 15, 2013 @ 1:35pm
Posts: 5