PooperScooper Jan 23, 2013 @ 4:55pm
Steam prevents computer from going to sleep/standby
I noticed the computer will not automatically go to sleep when Steam is running and a game has been launched atleast once. Even though nothing is downloading, the computer will not go to sleep. As soon as I exit Steam, the computer will standby/sleep after the elapsed time. Any idea what is preventing standby?

What's interesting is if I simply launch Steam, PC will go to sleep soon after being idle. Only once I launch a game then exit, the computer will not go to sleep automatically. Launching/exiting more games will not revert this. Only exiting Steam will fix this.

Thanks for the help
Showing 1-14 of 14 comments
< >
PooperScooper Jan 24, 2013 @ 5:56pm 
http://pastebin.com/HcjSSD6j

I'm using LucidVirtu to use the integrated GPU when not running games so the log doesn't have information on the discrete graphics I have on my machine.

Edit:
Here's log after setting dxdiag to use the discrete gpu:
http://pastebin.com/kQEx2ixP
Last edited by PooperScooper; Jan 24, 2013 @ 6:00pm
PooperScooper Jan 26, 2013 @ 7:40am 
This isn't a driver/MS update issue. This is a bug in Steam. All drivers are updated regularly, same as MS updates. How do I go about reporting this to the Steam devs?
levonepure Jun 9, 2013 @ 7:32pm 
Steam seems to fail to close an audio stream that it uses for something.

C:\Windows\system32>powercfg /requests
DISPLAY:
None.

SYSTEM:
[DRIVER] Realtek High Definition Audio (HDAUDIO\FUNC_01&VEN_10EC&DEV_0887&SUBSYS
_10438445&REV_1003\4&2ab41b84&0&0001)
An audio stream is currently in use.

AWAYMODE:
None.
levonepure Jun 9, 2013 @ 7:34pm 
After closing steam, its all clear.
Jessi Jun 10, 2013 @ 2:10am 
interesting! nice find levonepure
Last edited by Jessi; Jun 10, 2013 @ 2:11am
PooperScooper Jun 22, 2013 @ 6:55pm 
I can confirm this is the issue. A workaround is to use the powercfg -requestoverride on the realtek driver. This allows the machine to go to sleep when its supposesd to even with steam open. The only disadvantage is it ignores the audio streams for other things. For example, listening to music normally prevents sleep but now my computer goes to sleep while playing music.
Precedence Jun 20 @ 4:13am 
Gonna necro this and ask why hasn't this been fixed yet? It's been over a year and this bug is still in Steam
nikita.vsnkzl Jun 20 @ 4:14am 
ДА
PooperScooper Jun 20 @ 8:04pm 
Can confirm still facing this issue on Windows 8.1 as well
livingpro Jun 20 @ 8:06pm 
well try your pc setting to sleep every hour
PooperScooper Jun 20 @ 8:09pm 
Like i said, only way to get to sleep is manually. Currently set to sleep after 15 min idle. The workaround still works, but its a problem when viewing media since it ignores the driver request to not go to sleep.
Blade Jun 20 @ 8:10pm 
hum
Tomkun Nov 13 @ 9:12pm 
I'm going to raise this from the dead once more becasue I have this issue too and find it's more prevalent after using in-game chat.
[.TIG.]Stolas Nov 14 @ 12:43am 
if you have windows, look in the bottom right hand corner an you should see an arrow. if you click it and see the steam logo, steam hasnt closed all the way. may be the problem you're having
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Jan 23, 2013 @ 4:55pm
Posts: 14