Fafnir the Burninator Dec 29, 2012 @ 12:05pm
Unable to connect- Steam gets stuck on "Connecting steam account"
Since around the 5th, I've been unable to access Steam from my laptop, though I was able to access it from another computer just fine. When I try to get on, everything works fine until it displays the "Connecting steam account" message, at which point it gets stuck there until it closes on its own. It says in the taskbar that it's also trying to open "Steam Subscriber Agreement" although I never actually see this window.

I've submitted a question to Steam support, but still haven't gotten any answer from them. I have tried shutting down Avast, removing and refreshing my Steam files, and uninstalling and reinstalling Steam multiple times according to the instructions given. Any advice?
Last edited by Fafnir the Burninator; Dec 29, 2012 @ 12:07pm
Showing 1-1 of 1 comments
< >
UberDaan Mar 19, 2013 @ 7:05pm 
***POTENTIAL SOLUTION (for some)

My computer was crashing when starting Steam (at 'Connecting to account...'). I had tried several troubleshooting steps, as recommended by the steam community:

- Deleted .blob file, launch steam (fail)
- Deleted all appropriate files in program files\steam folder, launch steam (fail)
- Rebooted Router, launch steam (fail)
- Manually opened Steam ports on Router, launch steam (fail)
- Allow all Steam permissions through Antivirus/Firewall (Norton360), launch steam (fail)
- Rebooted Cable Modem, launch steam (fail)
- Uninstalled/Reinstalled Steam, launch steam (fail)
- Roll-Back Network Card driver, launch steam (fail)
- Updated Network Card driver, launch steam (fail)
- Updated Video card driver, launch steam (fail)
- Run Norton360, Ccleaner, and Malwarebytes scans, launch steam (fail)


The last thing I did was run dxdiag.exe. When it failed (computer crashed), I restarted and re-ran dxdiag.exe. It indicated there was an issue accessing DirectInput. When I googled that, it seemed like a driver issue (game controllers??). I then uninstalled all my usb drivers, and reinstalled them...VOILA! Steam started up and is now working.

I think the last update had something to do with this failure (a driver verification call to a game controller on startup?), but check DXDIAG.EXE and see if you have any failures.
Showing 1-1 of 1 comments
< >
Per page: 15 30 50
Date Posted: Dec 29, 2012 @ 12:05pm
Posts: 1