morten_varoy Dec 5, 2012 @ 8:43am
Steam - Error "Could not connect to Steam network"
Trouble with steam - again. Contacted support two days ago - still no answer :( I Now cant get access to games I paid for - which is annoying enough. I'm even more irritated when I cant get an answer/help from "Support".

Anyways - here is my discription of the trouble i'm having:
Trouble started after the latest update two days ago - the one who had that survey in it. After that I cant access my account. When I try to login it says: Steam - Error "Could not connect to Steam network". My internet connection is fine - how else could I write here :) The error message says it could be a problem with the Steam network. I only know I cant access Steam - and that support isnt answering me. I have stated proof to support that I own my account btw. Still no answer.

I got Avast full version virus program. I have windows 7.

Since getting support from support seems very unlikely I'm hoping that some of you out there could help me out. Any help and suggestions - I would be thankful for. A warning tho. I'm not good at computing - so any suggestions would have to be understandable for a say 5 yr olds level :)

Thanks in advance for any help folks!
Showing 1-15 of 18 comments
< >
morten_varoy Dec 5, 2012 @ 10:16am 
Thank you for the answer!

I have the latest avast version.

I have installed PeerBlock now. Havnt got a clue how to use it tho, What do I have to block do you think? I did choose to block p2p, spyware and advertising. Should I block http?
Last edited by morten_varoy; Dec 5, 2012 @ 10:17am
morten_varoy Dec 5, 2012 @ 10:19am 
Hey! Now it worked:)

Ever so grateful for your input. Thanks a lot:)
morten_varoy Dec 5, 2012 @ 1:13pm 
worked after i installed and updated PeerBlock. I dont know why tho!
Lancet Dec 6, 2012 @ 3:39pm 
No peerblock installed on my end and having the same issue. just started after the dec 5 update. i have tried starting using -tcp, recycled everything, removed hamachi. Looking for any advice here.
morten_varoy Dec 8, 2012 @ 9:14am 
Sadly this is still a problem today. It worked only a short while. Now I'm cut off again. Frustrating :( Same message as mentioned above. Happened after the update. Please help anyone - its really troublesome.
Rozonkomo Dec 8, 2012 @ 6:39pm 
Originally posted by morten_varoy:
Sadly this is still a problem today. It worked only a short while. Now I'm cut off again. Frustrating :( Same message as mentioned above. Happened after the update. Please help anyone - its really troublesome.
Happened to me today as well. Somehow I can get on my mobile account though. Just started today. In the past I've been able to fix it by restarting my computer or turning off the steam client in services before retrying. Neither of those has worked today.
morten_varoy Dec 8, 2012 @ 7:00pm 
I got help from SIGAMES forum (im mostly playing football manager). Got access now and it seems to be working.

I did refresh my steam files - like this;


How to remove and refresh your Steam files

How can I remove and refresh my Steam files?

Certain Steam issues may be corrected by removing and refreshing your Steam files.
Windows XP/Vista/7

Completely exit Steam and go to the folder called C:\Program Files\Steam\ (this is the default location for a Steam installation - if you set a different installation directory, you will need to browse to it).
Delete all of the files in this folder except:
The Steamapps folder and Steam.exe (If 'exe' is not visible, look for the black and white Steam icon)
Restart your computer.
Then, you will need to launch Steam.exe from within the Steam installation folder, and not from a pre-existing shortcut.
With Steam running, re-test the original issue.


Mac OSX

Completely exit from the Steam client.
Go to the folder Users/[username]/Library/Application Support/Steam
Delete all of the files in this folder except for SteamApps.
Restart your computer.
Launch Steam and re-test the issue.



If you are using Lion please do the following to enable your Library folder:

1. Open Terminal
2. Type chflags nohidden ~/Library
3. Close Terminal

You should see the Library folder available through the Go menu on the menu bar while holding the option key.

Note:

This process will not affect your currently installed games.
morten_varoy Dec 8, 2012 @ 7:12pm 
Got into account so thats progress. Now it says that FM 2013 is already running - any help on that one?

Also tried to play FM 2012. I get that loaded fine, but then it keeps reinstalling after few minutes. Cant be like this - surely? Steam must do better!
Flavelesss the Punisher Dec 9, 2012 @ 6:53am 
I still have this problem. But I noticed that it works on evenings in my country only. During morning or day time it just says cannot connect to steam network. Already wrote support a letter - no response..
morten_varoy Dec 9, 2012 @ 7:54am 
Yeah - support isnt good enough. Either that or make the program easier - so theres less need for support! Its wrong to base support on that customers will help each other.
morten_varoy Dec 18, 2012 @ 12:26pm 
Close this please.

Got help with my Steam problem from helpful people at SI games! Not impressed with steam support. And please check your updates before release - thanks.
psolem Dec 20, 2012 @ 3:54pm 
So what was the final solution?
morten_varoy Dec 23, 2012 @ 11:59am 
Originally posted by psolem:
So what was the final solution?

This:
Completely exit from the Steam client.
Go to C:\Program Files\Steam (or the Steam directory that was specified during installation).
Locate ClientRegistry.blob and rename this file to ClientRegistryOld.blob.
Restart Steam to allow the file to be recreated.
Launch game

Then I got crashdump:
"I also got a chrashdump named " v0.0.0.0 (2012.12.09 17.13.50).dmp"
Which want away after reinstalling FM 2013.

Must say Steam isnt user friendly, and surely something must be wrong with support and their testing of new versions.

However - I would very much like to know what I can do to prevent this from happening again. I would welcome an answer from Steam support.
Code_Red 15 Apr 25, 2013 @ 12:17am 
Is Peerblock important
morten_varoy May 2, 2013 @ 1:14pm 
I dont think it is. Maybe just a fluke that it worked for me a short while after I installed it.
Showing 1-15 of 18 comments
< >
Per page: 15 30 50