... Dec 4, 2012 @ 7:09am
Steam shows my games as not installed
Hi all,
I am having issues with Steam library after last Steam update - more than half of my games that are already installed are not recognized by Steam and there is again "install" oprion available.
Do you have similiar issue - any suggestions what can be done to remedy it?
Thanks,
Showing 1-15 of 61 comments
< >
ﮏә۷ Dec 4, 2012 @ 8:06am 
you may need to reinstall from Hardcopy or Steam if you haven't backed up your games. Hardcopy would be best as they will install quicker. Be sure to make backups through steam once they are reinstalled, this should help if there are any future errors.
If anybody knows a quick fix I'm sure they will post :)
Satoru Dec 4, 2012 @ 8:14am 
Were you using any 'steam mover' tools? As any games that used that methodology will show as uninstalled.
... Dec 4, 2012 @ 8:18am 
No, just launched Steam.
ZOID Dec 4, 2012 @ 3:20pm 
Steam updates yesterday (Dec 3) wiped out my Black Ops 2 games. The history is there but the games need to be downloaded, but to where?
Steam screwed up
Other games are still there.
SheepShanker Dec 4, 2012 @ 6:50pm 
I am having odd login issues, and all but 2 of my installed games have disappeared from the library, and won't launch them from the shortcuts either.
MiNus Dec 4, 2012 @ 7:15pm 
I am having this issue as well, and on top of commenting on it in the beta I'll mention it again here. Half of my games, if not more, show up as uninstalled, despite being in one place after the update involving big picture mode. I have not moved anything and can't figure out WHY certain games are showing up still and why others are not.
BluntForceTrauma Dec 4, 2012 @ 7:45pm 
Same here, all but one showing as not installed, if I try to install, it says not enough disc space.
dukeofducks Dec 4, 2012 @ 8:36pm 
Same. Skyrim and FarCry 3 preload are asking for reinstall. Data is there in the steamapps/common/skyrim folder. Won't let me redownload anything, says no disk space. Have over 1.5TB free. Also clicking on Steam->Settings->Download + Cloud->Steam Library Folders causes Steam to crash.
Last edited by dukeofducks; Dec 4, 2012 @ 8:36pm
MiNus Dec 4, 2012 @ 9:02pm 
@Dukeofducks: Wow, didn't think to try it. I can confirm that trying to set this crashes my Steam as well.

Edit: I've found a slight fix for this. I had given Steam its own HDD, but Steam tends to behave weirdly when you try to set installs to root dir. I created a folder named "Valve" (although I'd imagine any name would work), and launched Steam through that. When I go to reinstall my game, I pick the new directory and it verifies the existing files and restores the game to my list. Still terribly annoying, not to mention time consuming to go through many of your games to do it. The verifying existing files process can take around 2-10 minutes depending on the game, but I guess that's faster than waiting for 2/3rds of my library to re-download :/.
Last edited by MiNus; Dec 4, 2012 @ 9:06pm
... Dec 4, 2012 @ 10:57pm 
I created a ticket with Steam support but solved the problem myself before they replied.

I have separate drive for Steam and as Reda I installed everything to root directory.
Install error messages that Steam gave me made me think that it is the main problem now - so I moved steamapps folder and steam.exe to newly created folder and deleted rest of the files.

Relaunched Steam, let it update and most of the games were there showing properly as installed, some of them just needed to be "installed" but it was quick as Steam just checked local files and switched those to "play" status.

Anyway, it took me an hour or so and I believe it is a major f*** up from Steam to make me go thru this due to some update.
Last edited by ...; Dec 5, 2012 @ 4:06am
Zycuda Dec 5, 2012 @ 1:35am 
This also happened to me. I was on the last level of BioShock 2, and I had to leave so I shut down my computer, did what I had to then steam told me BioShock 2 was uninstalled when I came back. I ran then .exe so I could finish the game, so afterwards I clicked install on install and it just downloaded 200 mbs. I'm just going to guess that Steam had a small bug here and that it won't happen anymore.
FSBDavy Dec 5, 2012 @ 7:15am 
Same issue - After "Big Picture" suddenly half my games are gone and worse, despite lots of space (NOTHING else has been changed at all) Steam claims drive is full (it isn't)! :(
ZOID Dec 5, 2012 @ 11:22am 
Does anyone from Steam read these discussions ?? if so tell us you are aware of the problem !!
"Big Picture" seems to be a "Big Screwup"
Last edited by ZOID; Dec 5, 2012 @ 11:23am
TagAlongMan Dec 5, 2012 @ 3:27pm 
I too have this problem. any help other than all that uninstall reinstall would be great

Originally posted by ZOID:
"Big Picture" seems to be a "Big Screwup"
^^^^^thats no joke
Last edited by TagAlongMan; Dec 5, 2012 @ 3:28pm
Killdozer Dec 7, 2012 @ 10:36am 
Just make a new folder in your steam drive, install steam to that folder, cut & paste the contents of your steamapps into the new steamapps folder and don't forget to use the new steam installation's shortcut instead of your old one. That's what worked for me.
Showing 1-15 of 61 comments
< >
Per page: 15 30 50

Date Posted: Dec 4, 2012 @ 7:09am
Posts: 61