Sir Mentlegen™ Jun 7 @ 1:57pm
Weird Stuttering in L4D2, GMod and TF2.
(First of all, I'd like to say this right off the bat: I'm seriously stumped. I've tried everything that I can do and none of it's working. I really need some help or at least some information if people are having the same problems as me. Thanks for reading.)

It's been about a 2-3 weeks since my games have been acting up like this. But I can remember before a certain TF2 and Steam update happened, I was running on Highest settings, No lag with 60+ FPS. It's only when these updates happened is when I noticed that horrible stuttering. My PC's hardware is more than enough for TF2, L4D2 and GMod which is rather strange. I'll post my Specs right after this. I really have no last resorts, since like I mentioned before, I've tried updating my drivers, cleaning oout my PC and even reinstalled all 3 games. Alas, none of these worked, which sucks really friggin' bad.

If anyone else has this problem or has fixed it, please comment on how you did fix it because I quite am seriously about to lose my mind.

Thanks for your time-
Mentle.

=================================================
System Specs:
OS: Windows 8.1- 64 Bit
Processor: AMD-Quad Core-10-4655M- 3.6 Ghz APU with Radeon HD Graphics
Graphics Card: AMD Radeon 7620G+8600MDual Graphics
Ram: 8GB
=================================================
Showing 1-8 of 8 comments
< >
UberFiend Jun 7 @ 2:18pm 
Make sure it's using the 8600 & not the integrated gpu.

Can you describe the stuttering please?

Is there any odd CPU or Memory activity in Task Manager? (spikes, high usage, etc)
Last edited by UberFiend; Jun 7 @ 2:20pm
Sir Mentlegen™ Jun 7 @ 2:32pm 
Well. How could I make sure it's using the 8600?
The stuttering is sometimes like a second lag or in the wost case, it lasts for about 4 seconds and by that time I'm alredy dead. It occurs randomly.
And from what I know, the CPU and Mem is totally fine in game. I'll get back to you on that one.
Last edited by Sir Mentlegen™; Jun 7 @ 2:39pm
Sir Mentlegen™ Jun 7 @ 2:36pm 
Yeah, the CPU is fine and Memory is fine too. All okay here.
UberFiend Jun 7 @ 2:40pm 
Are your temps okay?

Not certain with igpu, try right-click desktop, Screen Res, Advanced Setting & see if you can change the adapter there.

Although they're AMD chips I don't think Catalyst Control Centre will do it.
Last edited by UberFiend; Jun 7 @ 2:44pm
Sir Mentlegen™ Jun 7 @ 2:43pm 
Temps are fine. Idle it's 35 degrees. In game it's 52 degrees.
UberFiend Jun 7 @ 2:45pm 
Sounds fine.
Sir Mentlegen™ Jun 7 @ 2:46pm 
Yeah that's what's confusing me. It SOUNDS and LOOKS fine, but in game it's anything but fine.
Sir Mentlegen™ Jun 14 @ 10:42am 
Fixed! Turns out it was my Core temp was running too hot so I sprayed some compressed air in there and, thank God, it fixed!
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Jun 7 @ 1:57pm
Posts: 8