Kitty Jan 14, 2013 @ 2:53pm
Steam is already running in a different Windows user session.
I know that this error has been said a lot in many posts, but none of the solutions that I have read have fixed anything. I have recently repaired my Steam to fix a problem that Windows said was there. So I downloaded the installer and repaired my steam. After that, my steam stopped working. Every time I start up my computer, I got an error message saying the exact message in the title. I have tried task manager and stopping the process but that doesn't work. I have tried opening the command prompt and using "taskkill /f /im steam.exe" but that doesn't work either. Its been like this for two days now.
I am currently using a Windows 8 Operating system.
Showing 1-11 of 11 comments
< >
[nBn] elli ♥ Jan 14, 2013 @ 3:06pm 
I am not on Windows 8, but I only get that message if I turn on my computer and manually try to click on Steam. Steam is set to automatically load on startup for my computer, so it was already trying to load until I clicked on it.

tl;dr check if your Steam client is set to automatically open on startup.
Kitty Jan 14, 2013 @ 3:36pm 
That is the problem, I cant OPEN the steam client to prevent it from starting up.
Flutters94 Jan 14, 2013 @ 3:58pm 
right click your task bar then hit task mang then go to processes the look for steam exe
them end task then dub click on steam icon
[DFS]CannibalSolly Jan 24, 2013 @ 12:52pm 
Hey, I'm having this problem too. It's been going on for a few days and I'm getting really frustrated.
I have been trying to do what XWolfyX94 suggested but that's the thing; the program WON'T. CLOSE. No matter how many times I turn off my computer or click "end program" in Task Manager, the little bugger won't close or go away. It just sits there, doing nothing.
It was working fine on Windows 8 when I first got my new computer, running my games without any problems. It has just run into this problem after I enabled airplane mode for a few days (I was staying at a place with no wifi so I saw no reason to keep it enabled) and it started having troubles going online once I did re-enable internet access. After I force-closed it, I started having this problem.
I really hope this is a bug that can be fixed...
yeeyoh Jan 24, 2013 @ 3:48pm 
No sure if it's the same in windows 8, but in previous versions of windows you would/could use msconfig.exe (its a program launch from programs or command prompt) from there you could turn off the option to have steam turn on at start up. After that maybe you could try to launch steam, when windows is already running, and change whatever settings you have to.
I would also try using taskmanager to see what and how many instances of steam are running and/or not responding...
Kitty Jan 24, 2013 @ 4:13pm 
Alright, so I fixed it up. All you have to do is stop Steam from running during startup as the guy above me said. Once you do that, just start steam by double clicking the icon on your desktop or in yout installation folder and it should run normally.
[DFS]CannibalSolly Jan 24, 2013 @ 4:17pm 
hUUAAAH It's running again!
Turns out mine got blocked by windows firewall as well for some reason...
Thanks!
cowboyaz96 Jan 26, 2013 @ 9:33am 
i am having this problem and i am having trouble following. what is msconfig.exe and how do i use it and how do i get t it?
schnitzeljaeger Jan 26, 2013 @ 9:38am 
Originally posted by cowboyaz96:
i am having this problem and i am having trouble following. what is msconfig.exe and how do i use it and how do i get t it?

Open the start menu (win7)/metro (win8) and type msconfig + hit enter :D
Sniper Pancakes Jan 27, 2013 @ 3:57pm 
I do everything and nothing works
[citation needed]™ Feb 14, 2013 @ 8:03pm 
Ok... so I have a computer with this problem and one that does not... so I checked the differences using an utility called autoruns (by Systeminternals aka microsoft). It turns out that there are two instances of steam that must be present in order for it to start properly: one is a service and the other is the regular client.

What happens is that while the service is running when the computer starts, the client does not. because somehow the entry that start it is missing. This is the reason why you see that message.

Now to the fix: In order to put an end to this annoying message you must add the entry manually to your windows registry:

Note that this procedure modifies the registry which controls how Windows works. I am not responsible for anything that happens to your system as a result of this procedure. You must have some med-advanced knowledge of Windows to implement this fix

Open regedit (by hitting Win+R, then type regedit, press enter and click on Yes to the UAC warning, if you get one)
Navigate to HKCU\Software\Microsoft\Windows\CurrentVersion\Run
Create a new entry, String type, name it Steam.
Double click on the entry (or right click it and select modify) and enter the path where steam.exe resides. (typically for x64: "C:\Program Files (x86)\Steam\steam.exe", for x86: "C:\Program Files\Steam\steam.exe")
Close regedit and reboot the computer
You should not get the annoying pop up anymore.
Last edited by [citation needed]™; Feb 14, 2013 @ 8:10pm
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Jan 14, 2013 @ 2:53pm
Posts: 11