[SMN] The Lumberer 18. nov, 2012 @ 6:36am
Connection is appalling.
I have a Virgin Media 30mbps internet connection and have ZERO problems on all my games except this one. I can play DCUO for hours with no trouble, Champions Online, no problem... yet Star Trek Online ALWAYS within about 5 minutes of playing spouts a "Server Not Responding" message and kicks me back to login.

I am getting sick of this as I cannot seem to maintain connection long enough to complete the first mission. I have tried setting the proxy to EU and US in the launcher options... nothing is working.


Please help?

Viser 1-5 av 5 kommentarer
< >
Centisteed 18. nov, 2012 @ 7:29am 
Did you email STO support? Maybe they're having an outage. I've played the game in the past & haven't had any issues. Been away for a bit & going to fire it up shortly though.
[SMN] The Lumberer 18. nov, 2012 @ 8:19am 
I tried to but their online form is terrible. Can't select the game to talk about and it keeps refreshing.
Asphe 21. nov, 2012 @ 3:01am 
Next time you get disconnected, do a continous ping test to patchserver.crypticstudios.com

If the ping -t is fine, than the gameserver has a problem with your connection. I'd suggest changing your IP (residential Virgin? Usually a quite router reset/etc, does the trick).
K*I*A 22. nov, 2012 @ 2:42am 
I've had this issues my self in the beginning for 2012, when I started sto. I still havent heard back on my attempts to make contact with cryptic to resolve this issue.
As luck would have it, I had a torrent client running in the background once I tried to play, and I could stay online for hours.
Not that I recoment using torrents, but doing so may help your connection issues
[SMN] The Lumberer 22. nov, 2012 @ 7:30am 
It's utterly absurd that you need to have a torrent running to keep the STO connection stable but it does work...

Confirmed, yet weird, fix.
Viser 1-5 av 5 kommentarer
< >
Per side: 15 30 50
Dato lagt ut: 18. nov, 2012 @ 6:36am
Innlegg: 5