Captin Flamex Jan 5, 2013 @ 2:17pm
just downloaded the game launcher isnt appearing
whenever i hit play the cryptic launcher is shown in task manager but i cant really see it it just doasnt work its in taskmanager and when i hit play on steam again it says already running
Showing 1-10 of 10 comments
< >
Captin Flamex Jan 5, 2013 @ 2:58pm 
im on windows 8
Captin Flamex Jan 5, 2013 @ 4:43pm 
it also said trying update launcher 1 time connecting then nothing
John Knackitiello Jan 6, 2013 @ 1:09pm 
Um, are you on a laptop by any chance? The game recently has been having some issues with integrated graphic cards and also people haven't been able to run it on Windows 8 either.

Try this link: http://sto-forum.perfectworld.com/forumdisplay.php?f=70
And look around for an answer there, you'll find one faster and better than on here.

Good luck!
K'mPeK Jan 6, 2013 @ 3:24pm 
I've not been able to play in months.. "connection to server has timed out"...is all i'm getting...good thing i've got swtor to play instead...
rafi.bokhari Jan 7, 2013 @ 4:22am 
For all Launcher issues, go here to find the latest launcher exe:

http://sto-forum.perfectworld.com/showthread.php?t=505501
Darkhonor Jun 19, 2013 @ 7:00am 
I have the same thing happening. It worked fine for a while, but now it's disappeared. I made a second account on my computer, and strangely it works fine there, but I don't want to be using this second account all the time!!!
Ishan451 Jun 19, 2013 @ 1:51pm 
Create a shortcut outside Steam, rightclick the shortcut, select properties. Look for the entry that says: Run: <drop down box saying normal window>. click the drop down box and select Maximized window. Save.

Run the luncher from the shortcut. Curse Cryptic for once again shoddy work.
TyberZann Jun 21, 2013 @ 1:00pm 
ishan451 how the ♥♥♥♥ do you do that
OCC Jun 21, 2013 @ 5:27pm 
try this it worked for me:)
fix your launcher by going to properties, and setting the game launch into maximized
TyberZann Jun 26, 2013 @ 4:17pm 
thanks you i got it
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Jan 5, 2013 @ 2:17pm
Posts: 10