Star Trek Online

Star Trek Online

View Stats:
OzForce May 21, 2013 @ 5:00pm
Damnit PWE servers, WORK DAMNIT!!!
So i just finished school and decided to go and see how STO is doing on their website, so i typed it into google and clicked on it. So when it didn't come up i was just like: ''huh, this happens sometimes...'' and then i proceed to look at the address and type it into my address bar, and so it doesn't load. And so i closed that browser and typed it in again, and it seems that i got an error. This probably means that you are pushing their servers so hard that their servers went offline.
< >
Showing 1-3 of 3 comments
Lvl.100 Jolteon May 21, 2013 @ 6:27pm 
dude chillaze
Robert Maxfield May 21, 2013 @ 6:49pm 
did this with me i was patching up neverwinter like for first time i installed everyhting been on never witner twice and it saying not found and popping up wedsite also saying address not found i now neverwitner was not long opened up for people so maybe its that so many people patching and stuff they game goes funny until its sorted
Robert Maxfield May 21, 2013 @ 6:53pm 
not had problem since with neverwinter then the same thing happens with STO got a patch for new bits same problem could not access launcher probley i access it and itsl ike address not found all i do is reinstall everything and should work ok then i mean startrekonline not everything on your pc and reinstall should be fine i did it with neverwinter hope this works out for u best leavign game a day or two for people to settle then you might have success acceccing the game
< >
Showing 1-3 of 3 comments
Per page: 15 30 50

Date Posted: May 21, 2013 @ 5:00pm
Posts: 3