TheCookiemob May 1, 2013 @ 12:49pm
Last edited by TheCookiemob; Jun 14 @ 12:52pm
Showing 1-15 of 22 comments
< >
unclerayray May 1, 2013 @ 4:13pm 
Bump. I'm getting the same error.
Farodered May 2, 2013 @ 12:33pm 
Yes me too ! I restarted my pc, reinstalled it, even without steam, autorepaired it, switched the autopatcher and nothing worked x.x pleaaaaaseee help :(
puddles May 2, 2013 @ 6:22pm 
same wtf how do i fix this
madtadpole May 2, 2013 @ 6:25pm 
I have the same issue.
Sebensul May 2, 2013 @ 6:29pm 
Maybe try calling customer support? Cuase I have the same problem
CentralCompute May 2, 2013 @ 6:38pm 
Same Problem. Probabley the actual game, just have to wait
Addtheking May 2, 2013 @ 6:39pm 
same
Addtheking May 2, 2013 @ 6:40pm 
niether doe website
[TWP] Mazzarc May 2, 2013 @ 6:42pm 
yeah i got the same problem. i have been searching the forums but havent found anything that has worked :/
timmis75 May 2, 2013 @ 6:43pm 
me to!! time for bed then i guess.....
[TWP] Mazzarc May 2, 2013 @ 6:45pm 
the game devs just tweeted that they are working on a patch now and we should get it soon ill post an update when they release it
Mastah Jedi May 2, 2013 @ 7:01pm 
can u link their tweeter some1 ?
Sayne May 2, 2013 @ 7:02pm 
The server is down. http://www.mmoserverstatus.com/star_trek_online
Nothing to do but wait for Cryptic to fix it.
Mastah Jedi May 2, 2013 @ 7:24pm 
thank you mazzarc, cheers o/
Showing 1-15 of 22 comments
< >
Per page: 15 30 50
Date Posted: May 1, 2013 @ 12:49pm
Posts: 22