TheSputNic Mar 18, 2013 @ 2:46pm
How do you launch the game?
When I try to launch the game from steam it starts patching and never patches. I also can't right click and manage account because nothing happens when clicked. Please help??
Showing 1-6 of 6 comments
< >
TheBlackDouglas ® Mar 19, 2013 @ 7:24pm 
Well 1st off id ask did u actually create an account at www.startrekonline.com?
Remember also theres like 2 companies or groups within it you need too create ur account with...
One being cryptic... Also as usual make sure ur steam on properties is set too run as administrator along with any game u play on ur comp or gaming software and you should be fine...
However if u still have trouble id suggest downloading and running it through the website/download again at www.startrekonline.com
Good luck n have fun...
TheSputNic Mar 20, 2013 @ 2:18am 
Already have accounts with both the problem is that when I try to launch the game the launcher wants to update then fails
TheBlackDouglas ® Mar 20, 2013 @ 2:32am 
well thats v strange... have u tried uninstalling and reinstalling it?
Also id recommend downloading it through the website an see if that works...
I used too run the game through its launcher untill i got it on steam later...
Id recommend sending them a problem report both cryptic and steam...
But try the games launcher through the website n see how that goes...
If its still playin up later on add me as a friend n il try n help u out more and il also ask my fleet mates later on for ya also...
Good luck...
Last edited by TheBlackDouglas ®; Mar 20, 2013 @ 3:03am
TheTingler Mar 21, 2013 @ 2:05pm 
Yep, had the same problem. Go here: steam://openurl/http://sto-forum.perfectworld.com/showthread.php?t=504341

Download the updated launcher and put it in your Steam folder for the game, overwriting the current version there. It should work then.
TheSputNic Mar 21, 2013 @ 2:42pm 
Thanx a lot. I just need to patch it now but that's further than it's gotten ever.
Last edited by TheSputNic; Mar 21, 2013 @ 2:43pm
Szeron Mar 21, 2013 @ 5:04pm 
Yeah, it's an unfortunately problem that crops up every now and then for different people. I've probably had to manually replace the launcher.. 3?.. times in the past year or so.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Mar 18, 2013 @ 2:46pm
Posts: 6