Joseph Stassup Dec 7, 2013 @ 6:57pm
So STO launcher won't load.
I click on the icon on thec desktop, and nothing happens.
Earlier it said I was missing a certain file, but after my machine had a scan, it stopped.
But now it does nothing. I don't know what to do.
Right now, I'm deleting the current file I have of the launcher, and redownloading it.
If that doesn't work, then I'll hit my computer with a hammer until it works.
Showing 1-11 of 11 comments
< >
grizster Dec 7, 2013 @ 8:23pm 
i've been launching it with steam if i try from desktop it dont work
Joseph Stassup Dec 7, 2013 @ 9:25pm 
Yeah, still not working.
grizster Dec 7, 2013 @ 9:38pm 
are you running anything like a movie etc.. in the backround?
Joseph Stassup Dec 7, 2013 @ 9:54pm 
Nothing except skype for my fleet buddies.
grizster Dec 7, 2013 @ 10:29pm 
grizster Dec 7, 2013 @ 10:30pm 
strting to wish i never used steam not having issues atm but was at first
grizster Dec 7, 2013 @ 10:39pm 
was just told by fleet mate to tell ya shut down steam and launch threw desktp shortcut
grizster Dec 7, 2013 @ 10:40pm 
shortcut in steam folder
Joseph Stassup Dec 8, 2013 @ 7:40pm 
Nothing is working.
d.jamo Dec 15, 2013 @ 1:33am 
I am having this trouble too, sayings it is uploading launcher however it just keeps going in a circle, once i have been patient for it to update the 20mb it the starts all over again, tryed some of suggestions in this post but none have worked for me. any assistance apprectiated
Joseph Stassup Dec 17, 2013 @ 2:42pm 
It's not even saying that for me.
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Dec 7, 2013 @ 6:57pm
Posts: 11