Star Trek Online

Star Trek Online

View Stats:
Darth Vader Feb 20, 2014 @ 7:16pm
Does this game even work???
All I get is Cryptic Launcher continually trying to update, have not even seen a start screen? anyone else got past this?
< >
Showing 1-15 of 15 comments
Darth Vader Feb 21, 2014 @ 1:11am 
is this game trying to work of US servers???, still not having any luck starting this game
Shannon Fartacus Feb 21, 2014 @ 11:32am 
i tihnk, there was an update yesterday... can it be, that youre control-program is still downloading this update?
Darth Vader Feb 22, 2014 @ 3:10am 
finally, got to the main screen, but now is trying to download another 9gb?... is it worth it?
Shannon Fartacus Feb 22, 2014 @ 4:08am 
9 GB is very much! My complete STO installation has 7,86 GB. Perhaps steam is downloading another update too? On the other hand, you must decide it for yourself if it's worth... for me the game is funny...
Velhym Feb 23, 2014 @ 2:31am 
When you intially "Install" Star Trek Online from Steam, you'll download some key system files and the game's launcher. Once you sign in to the launcher for the first time, the game will patch up whatever differences they be between the data you have and whatever the game running, pure and simple. This will likely be many gigs of new data and old being rewritten. Currently, my STO installation sits at 12.9GB.
Darth Vader Feb 23, 2014 @ 3:16am 
thanks for information.
Shannon Fartacus Feb 23, 2014 @ 7:26am 
i thank you too! good to know!
Tainted Feb 23, 2014 @ 1:38pm 
lol Yeah I use to run this game on my old AMD quad core PC fine. Just built a new PC this past winter & out of 130 Steam games & 5 Origin games this is the only one that wont work. Getting a bsod on install from the launcher. Checked drivers multiple times, switched RAM from another PC, switched GPU's, & still no go. This game really does not like AMD & was badly coded.

CPU: AMD 8320 Black Edition 8 core 3.5Ghz/4.2Ghz OC
Cooler: Cooler Master Hyper 212 plus +Artic Silver 5 Goo
Mobo: Gigabyte 970A-D3P AM3/AM3+
RAM: Gskill Ripjaws X 16Gbs-2x8GBs 1866Mhz ----tryed 8gbs 4x2gbs kingston 1333mhz
GPU: MSI Radeon HD7870Ghz OC Edition ------tryed xfx hd 5570
Hdd: Sandisk 128GB SSD boot drive
2x1Tb Hitachi 7200RPM Hdd
2Tb WD MyBook 7200RPM external Hdd
PSU: Rosewill Hive 650W 80+Bronze Full Modular
Case: Rosewill Challenger USB3.0v Mid-tower
OS: W7 64bit Home premium
Velhym Feb 23, 2014 @ 2:10pm 
I hear about graphical bugs quite frequently with people who have AMD cards. Some are just fine, so I suspect it may be a driver or configuration issue. I'm sure it depends on a case to case basis. Find it interesting that you'd BSOD just opening the launcher. That doesn't make a bit of sense, since all the launcher does is patch files to your machine.
Tainted Feb 23, 2014 @ 4:00pm 
Well I seemed to have fixed my bsod launcher problems. I went into event viewer & googled the 6 error codes I got. Came across a person with the exact same problem on a different game that I had in a random forum. Turned out their Norton anti-virus was the problem & some W7 desktop gadgets + monitoring programs can cause issues.
I turned off:
avast
malwarebytes
IObits malwarefighter
turned off desktop gadgets/ monitoring:
calender
digital date/time
cpu meter,gpu meter + temp monitor addon
msi afterburner/rivaTuner monitor overlay
AdvancedSystemsCare7/ performance monitor gadget

Find it weird in 12 years of PC gaming never had a problem like this one. Online forums everyone's 1st reactions are its a hardware/driver or ATI/AMD compatibility problem. Any hoo I m curently 7Gbs out of 8.5Gbs done downloading now. Hope this helps anyone having similar issues.
Last edited by Tainted; Feb 23, 2014 @ 4:08pm
Velhym Feb 23, 2014 @ 6:21pm 
Good bit of troubleshooting there! I definitely suspected something other than video card direct involvement because really, I can't imagine there would be a thing that the GPU would do with the launcher up. STO isn't a game where the launcher and game client are one in the same, like Guild Wars 2 or Wildstar or whatnot. The STO launcher can easily be bypassed to start the game by using the game client executable directly.
Tainted Feb 23, 2014 @ 7:24pm 
Yea I thought the same thing. Kinda weird to have this problem though usually if a program is blocking something the game will just crash to desktop. Not crash W7 to a blue screen of death error code. Game works great now, just gotta narrow the problem down to the exact program causing this mess. So I dont have to turn every darn app off every time I wanna play some STO.
Velhym Feb 23, 2014 @ 7:50pm 
Yeah. :|

I can't imagine that any of the monitoring utilities would cause the issue. The multiple AV/Malware apps might though. Patching the game involves a lot of incoming file activity that may have caused those apps to go a little haywire.

The launcher as an application does have several components to it. I remember much earlier iterations of it caused some odd issues with script/ad/AV softwares. Some of the content would be pulled from the community site, other parts from a different part of (at the time) Atari's network, and then file checks itself would look for the game server listings. I vaguely remember a time when a software I used aged ago tried to block the center content of the launcher (links and scrolling images). It was so long ago that I don't really remember, but at least that might help you get started.
zealtobeatU Feb 26, 2014 @ 11:04am 
I think that it does work but I looked on the website and they said that they had moved the game to Arc.
Originally posted by Darth Vader:
All I get is Cryptic Launcher continually trying to update, have not even seen a start screen? anyone else got past this?
< >
Showing 1-15 of 15 comments
Per page: 15 30 50

Date Posted: Feb 20, 2014 @ 7:16pm
Posts: 15