aecepoglu Feb 20, 2013 @ 9:15am
File permission error (linux)
I have the game installed through steam on my linux machine. When I start it through steam or through the console, I see its splash screens, hear the audio, but I get a file permission error and can't proceed any further.

The messagebox is titled "File Access Problem" and it suggests I run it under admin or install in program files. I am able to start it under root.

When I check the console, I see plenty of "File IO error: Permission denied" messages.
The last of such messages is for psychoff/testWrite.txt; and that's when the messagebox shows.

I have made sure my user has r,w,x writes on every file. What am I missing?
Showing 1-2 of 2 comments
< >
James  [developer] Feb 20, 2013 @ 9:58am 
Hi,
Which distribution of Linux are you using?

Frozen Synapse does its file writes to a hidden folder with the location ~/.local/share/FrozenSynapse/ in case you want to narrow down which permissions you want to set.
aecepoglu Feb 20, 2013 @ 10:40am 
It's archlinux, and cheers, that solved my problem.
Apparently the .local folder was already existing, and belonged to the root user. Nasty!
Showing 1-2 of 2 comments
< >
Per page: 15 30 50
Date Posted: Feb 20, 2013 @ 9:15am
Posts: 2