Frozen Synapse

Frozen Synapse

Προβολή στατιστικών:
Frozen Synapse > Γενικές συζητήσεις > Λεπτομέρειες θέματος
Linux bugs?
I'm currently trying out the Steam Linux beta and I've noticed a few problems with Frozen Synapse that I didn't have on Windows.

Firstly, CTDs. Crashing to Desktop is, I think, related to YouTube uploading but I'm not entirely sure.

There's also an issue with YouTube credentials not being saved, even with the box ticked. This means I have to alt-tab out and create a new program-specific two-step verification key each time I want to upload something.

And seeds are not being saved for missions completed, which means I cannot share the seed for the level after uploading a single player mission video.

I'm also having trouble logging in to the master server when the game starts up, though that only started recently and could be a network error.
Τελευταία επεξεργασία από Retron; 22 Ιαν 2013 στις 9:14πμ
< >
Εμφάνιση 1-9 από 9 σχόλια
I'm having an issue under Linux as well. On my Fedora 17 system under Steam none of the text displays. It starts up with lovely blue boxes and text entry areas and everything. Just not a scrap of actual text. Not a single letter.

I suspect a missing font. But I'm not sure which one it wants.
James  [δημιουργός] 18 Φεβ 2013 στις 3:06πμ 
arrjaylee, does this happen while the video is being uploaded or while the match is being recorded?

Omnifarious, there's a file called console.log in ~/.local/share/FrozenSynapse/
Please email that to jimmeh@mode7games.com
It was happening during the upload. Recording was fine.
James  [δημιουργός] 18 Φεβ 2013 στις 9:40πμ 
arrjayjee, in the meantime there should be a file called record.ogv in ~/.local/share/FrozenSynapse which is the recording that is uploaded. Try uploading this using the YouTube website uploader. I realise this is not ideal and we'll get it fixed.
Αναρτήθηκε αρχικά από Omnifarious:
I'm having an issue under Linux as well. On my Fedora 17 system under Steam none of the text displays. It starts up with lovely blue boxes and text entry areas and everything. Just not a scrap of actual text. Not a single letter.

I suspect a missing font. But I'm not sure which one it wants.
I'm getting the same thing, but other than a few people mentioning the same problem, I've yet to find a solution mentioned anywhere.
Found the fix, at least for ubuntu 64bit based distros. (I'm using Mint)

http://forums.mode7games.com/viewtopic.php?f=21&t=3626&start=15#p14437

The sad thing? This is a known bug... from 2011. Still not fixed in the release.
I have such a bug:



./FrozenSynapse: error while loading shared libraries: libSDL-1.2.so.0: cannot open shared object file: No such file or directory

ubuntu 14.04 64bit

edit
apt-get install libsdl1.2debian:i386

now i have:

Alert: Error Could not find a compatible OpenGL display resolution. Please check your driver configuration.
Exiting

Τελευταία επεξεργασία από Pawel (LINUX); 25 Σεπ 2014 στις 10:15πμ
I have the same bug as Pawel on elementary OS which is also based on ubuntu 14.04 64bit. Any solutions to this?
Ah nevermind. I fixed it creating the "~/.local/share/FrozenSynapse/common/preferences/pref.cs" file and adding my desired resolution "$pref::Video::Resolution = "1920 1080 32";"
< >
Εμφάνιση 1-9 από 9 σχόλια
Ανά σελίδα: 15 30 50

Frozen Synapse > Γενικές συζητήσεις > Λεπτομέρειες θέματος