Frozen Synapse > Discussions générales > Détails du sujet
arrjayjee 22 jan 2013 à 9h13
Linux bugs?
I'm currently trying out the Steam Linux beta and I've noticed a few problems with Frozen Synapse that I didn't have on Windows.

Firstly, CTDs. Crashing to Desktop is, I think, related to YouTube uploading but I'm not entirely sure.

There's also an issue with YouTube credentials not being saved, even with the box ticked. This means I have to alt-tab out and create a new program-specific two-step verification key each time I want to upload something.

And seeds are not being saved for missions completed, which means I cannot share the seed for the level after uploading a single player mission video.

I'm also having trouble logging in to the master server when the game starts up, though that only started recently and could be a network error.
Dernière modification de arrjayjee; 22 jan 2013 à 9h14
Affichage des commentaires 1 à 7 sur 7
< >
Omnifarious 17 fév 2013 à 22h45 
I'm having an issue under Linux as well. On my Fedora 17 system under Steam none of the text displays. It starts up with lovely blue boxes and text entry areas and everything. Just not a scrap of actual text. Not a single letter.

I suspect a missing font. But I'm not sure which one it wants.
James  [développeur] 18 fév 2013 à 3h06 
arrjaylee, does this happen while the video is being uploaded or while the match is being recorded?

Omnifarious, there's a file called console.log in ~/.local/share/FrozenSynapse/
Please email that to jimmeh@mode7games.com
arrjayjee 18 fév 2013 à 3h53 
It was happening during the upload. Recording was fine.
James  [développeur] 18 fév 2013 à 9h40 
arrjayjee, in the meantime there should be a file called record.ogv in ~/.local/share/FrozenSynapse which is the recording that is uploaded. Try uploading this using the YouTube website uploader. I realise this is not ideal and we'll get it fixed.
Mows 19 juin 2013 à 17h59 
Omnifarious a écrit :
I'm having an issue under Linux as well. On my Fedora 17 system under Steam none of the text displays. It starts up with lovely blue boxes and text entry areas and everything. Just not a scrap of actual text. Not a single letter.

I suspect a missing font. But I'm not sure which one it wants.
I'm getting the same thing, but other than a few people mentioning the same problem, I've yet to find a solution mentioned anywhere.
Mows 19 juin 2013 à 18h27 
Found the fix, at least for ubuntu 64bit based distros. (I'm using Mint)

http://forums.mode7games.com/viewtopic.php?f=21&t=3626&start=15#p14437

The sad thing? This is a known bug... from 2011. Still not fixed in the release.
Pawel (LINUX) 25 sept à 9h51 
I have such a bug:



./FrozenSynapse: error while loading shared libraries: libSDL-1.2.so.0: cannot open shared object file: No such file or directory

ubuntu 14.04 64bit

edit
apt-get install libsdl1.2debian:i386

now i have:

Alert: Error Could not find a compatible OpenGL display resolution. Please check your driver configuration.
Exiting

Dernière modification de Pawel (LINUX); 25 sept à 10h15
Affichage des commentaires 1 à 7 sur 7
< >
Par page : 15 30 50