kazaric May 15, 2013 @ 12:19pm
Here's how you easily fix the game! No more startup errors!
First of all, download a file from here (all credit goes to tomsons26)
http://www.moddb.com/downloads/proper-windows-7-fix-for-act-of-war

****But here's the thing, the guide is somewhat misleading so do not follow the guide there, instead, do this :
Ignore the EugLoadingBar the guide told you to, set only the ActofWar.exe in Vista SP1 compatibility mode
Apply the dll you downloaded from there.

Then you should be able to run the game, HOWEVER -> some people may experience another error caused by the "Run as Admin?", if this happens to you, try unchecking the "run as administrator" box in ActofWar.exe, if it still doesn't work you will have to try fiddle around with your Windows Security options, If you can get rid of the question box, the game WILL guarantee to run trust me.

Please spread this info to your friends as well if they can't get the game running, they need to know this, hopefully with this thread it can be more visible to you people.
Last edited by kazaric; Jun 28, 2013 @ 12:44pm
Showing 1-15 of 26 comments
< >
z.s May 19, 2013 @ 12:19am 
how do u set compatibility mode to Vista SP1
kazaric May 19, 2013 @ 4:47am 
Right click on ActOfWar_HighTreason.exe and click compatibility then select Vista SP1 hope this helps.
Lion May 23, 2013 @ 10:49am 
yes this is the solution which we ware waiting ,it worked ! it's Alive!!! finally. steam should make this file as update for the game
Last edited by Lion; May 23, 2013 @ 10:50am
kazaric May 23, 2013 @ 11:19am 
Yeah well but there are still some bugs and the steam version being unupgraded therefore can't use mods like Naval invaders, it's too bad but I guess we'll have to make do with what we got, such masterpiece like this got overlooked and ignored simply because of problems like these are just heart breaking
HelixShade May 27, 2013 @ 8:35am 
Nope, this still isn't working for me. Having the exact same problems with my Retail copies -_-
Shifty141 May 28, 2013 @ 11:28am 
If i remember correctly, you have to go to msconfig > boot > adv options and set processors to 1 and max memory to 2048, then restart. This works with AoW:DA, I'll try HT in a bit
Shifty141 May 28, 2013 @ 11:35am 
works with HT, no problems.
war_head202 Jun 15, 2013 @ 11:22pm 
wait how do i set compatibility for just AOW? i can for steam and other non steam programs but not the steam games themselves? also steam games dont have a game folder where do i put the file?
kazaric Jun 15, 2013 @ 11:40pm 
..........................man, it's in your steam folder, steamapps\common\Act of War High Treason
war_head202 Jun 16, 2013 @ 11:27am 
thanks man im so glad this game finally works!!
Shtu123 Jun 25, 2013 @ 7:56am 
Does this fix work the Non-steam edition? Becuase I have tried it although the grammar makes it difficult to work out what you should do... Yet I still get runtime error 217.
Shtu123 Jun 25, 2013 @ 9:05am 
Update
I have set all applications ending in .exe to run as admin
I have set the Loading bar thing to run as XP SP2
Still getting runtime error 217

For direct action the game will load, but only to 69% then I get some strange error message in a foreign language and ideas on what to try?
kazaric Jun 25, 2013 @ 10:38am 
For me XP didnt work ok? why not just listen to me and try Vista?
Shtu123 Jun 26, 2013 @ 4:38am 
Sorry forgot to include that I had tried that too.
kazaric Jun 26, 2013 @ 5:51am 
Ok I am sorry, but try this, remove the compatibility mode in EugLoadingBar.exe and set only ActOfWar_HighTreason.exe in Vista SP1, I just did a test and it worked for me without any problems.
Last edited by kazaric; Jun 26, 2013 @ 5:51am
Showing 1-15 of 26 comments
< >
Per page: 15 30 50