Magic: The Gathering - Duels of the Planeswalkers 2013
Docsmethane Nov 6, 2012 @ 2:09pm
The game doesnt run
Just bought and downloaded the game and the ran it (from the run now its done screen, the taskbar (windows 7 64bit) and from the steam library) and all that happens is the screen flashes black a few times then it minimizes. i tried looking through previous posts and cant c anything about that.

Any ideas of how to fix it/if it can be fixed? Or even what the problem is. anything...
Showing 1-15 of 19 comments
< >
Panimu Nov 6, 2012 @ 2:42pm 
Ditto.. or close to. I get an error window! It says.. "Unknown error"

There is an error log in:
\Program Files (x86)\Steam\steamapps\common\Magic 2013

But for me it just uselessly quotes a CPP line
Panimu Nov 6, 2012 @ 3:00pm 
I got past my [Fatal Error] "Uknown Error" by editing the Config.cfg resolution to match my Windows desktop resolution.
Docsmethane Nov 6, 2012 @ 3:21pm 
Where did u find that file? all i got are empty directories
Docsmethane Nov 6, 2012 @ 4:48pm 
ok found it and tried it. The resolution was wrong but its still not working.
Any other tips are appreciated
Docsmethane Nov 6, 2012 @ 5:44pm 
Fixed it.
For me it wasnt the resolution. Well it might have been but i changed that in the config file and also changed it the value of Windowed from 1 to 0. or the other way round, whatever the case,
its now fixed!
the game works absolutely fine.
zeroxxx Nov 6, 2012 @ 6:08pm 
Try, if you have missing decks after saving/uploading, you're screwed.
Lunch Nov 6, 2012 @ 7:26pm 
so how do you actually fix the problem?
InfernoCerberus Nov 6, 2012 @ 7:43pm 
Originally posted by Lunch Time:
so how do you actually fix the problem?

Go to your Magic 2013 folder in "C:\Program Files (x86)\Steam\SteamApps\common\Magic 2013" (or something close to that) and locate the file "config.cfg". Open it with wordpad or notepad and it should look something like this:
[width]
1920

[height]
1080

[refresh]
60

[aa_mode]
1

[depth]
32

[fullscreen]
0

[reflections]
0

[language]
0

[quality]
1

[SFX]
1

[NumShadow]
3

[ShadowQual]
1

Change your width and height to your desktop resolution and change fullscreen to 0. Both of those changes fixed it for me. Hope it does the same for you. Good luck!

Side note: Always a good idea to verify that the files downloaded correctly when you first download a game. You can do this by right clicking the game in your Steam library and selecting Properties > local files > verify integrity of game cache.
Kaen Nov 7, 2012 @ 6:07pm 
For me, it's always been the refresh. For some reason, it defaults to 50 on my machine (for both Magic 2012 and this one). I change it to 60 (to match my monitor settings) and nothing else, and I'm in business.
Docsmethane Nov 8, 2012 @ 4:27am 
What Inferno Cerberus said.
I also redownloded the game before thinking of changing fullscreen to 0. The redownload did nothing for me.
Incidentally, im dualscreening from a laptop. So that might have confused the game somewhat i suppose.
sasquatc4 Nov 8, 2012 @ 10:04am 
I got the same issue on win8 except I dont even get a flashing screen. I checked the dir and I dont even have a config.cfg. I tried re-verifying the cache and it never shows up

Also every time i verify it says 1 file is bad, redownloads a 576 byte file, and still doesnt work
Last edited by sasquatc4; Nov 8, 2012 @ 10:07am
Docsmethane Nov 8, 2012 @ 11:35am 
Sorry, Widows 7 here, no idea how to fix download errors.
sasquatc4 Nov 8, 2012 @ 12:41pm 
Its not really a download issue, I tried the old fix for 2012 of copying d3d9 and the game at least tries to run but then crashes
SaintOfAllKillers Nov 17, 2012 @ 9:56pm 
sasquatc4 , i have same problem on win 7 576byte file will not verify , crashes at start screen every time, support has so far been useless , I have 47 other working games on steam, going to try rick's dll file found here
http://www.slightlymagic.net/forum/viewtopic.php?f=102&t=7426
SaintOfAllKillers Nov 18, 2012 @ 11:26am 
rick's dll is apparently only for deck fixes and card play issues, I did find out to take all the wmv files in the c:programfiles/steam/steamapps/common/magic2013/movies and put them in a sub folder which i called tryingtofix , this made it so the game cannot access the wmv's , with out deleting them, now the game runs fine
the problem must be how the game accesses the wmv's or maybe a codec issue but so far sasquatc4 is the only other person i can find with the same issue as me.
so if inferno cerberus's fix did not work for you try this.
Showing 1-15 of 19 comments
< >
Per page: 15 30 50
Date Posted: Nov 6, 2012 @ 2:09pm
Posts: 19