Solar 2 > General Discussions > Topic Details
Etique57 Feb 3, 2013 @ 8:11am
[Linux] Solar2 just stops
Hi,

What a wonderful surprise ! Bought it after reading the description and it's just great.

I've been playing for 1h+ without any problem. But since then, Solar constantly crashes after a few minutes of play, no matter what I do. Here's a nice stacktrace for your debugging pleasure :)

Stacktrace:

at (wrapper managed-to-native) Tao.Sdl.SdlMixer.Mix_PlayMusic (intptr,int) <0xffffffff>
at Microsoft.Xna.Framework.Media.Song.Play () <0x0007b>
at Microsoft.Xna.Framework.Media.MediaPlayer.PlaySong (Microsoft.Xna.Framework.Media.Song) <0x00073>
at Microsoft.Xna.Framework.Media.MediaPlayer.Play (Microsoft.Xna.Framework.Media.Song) <0x0004b>
at Solar2.Moosic.PlayTrack (string,bool) <0x00067>
at Solar2.Moosic.Update (single) <0x000f7>
at Solar2.World.Update (single) <0x00427>
at Solar2.Epsilon.Update (Microsoft.Xna.Framework.GameTime,bool,bool) <0x000ab>
at Power.PowerMain.Update (Microsoft.Xna.Framework.GameTime) <0x00751>
at Solar2.Main.Update (Microsoft.Xna.Framework.GameTime) <0x0033f>
at Microsoft.Xna.Framework.Game.DoUpdate (Microsoft.Xna.Framework.GameTime) <0x00038>
at Microsoft.Xna.Framework.Game.Tick () <0x0069f>
at Microsoft.Xna.Framework.OpenTKGameWindow.OnUpdateFrame (object,OpenTK.FrameEventArgs) <0x0003b>
at (wrapper delegate-invoke) <Module>.invoke_void__this___object_FrameEventArgs (object,OpenTK.FrameEventArgs) <0xffffffff>
at OpenTK.GameWindow.OnUpdateFrame (OpenTK.FrameEventArgs) <0x00019>
at OpenTK.GameWindow.OnUpdateFrameInternal (OpenTK.FrameEventArgs) <0x00034>
at OpenTK.GameWindow.RaiseUpdateFrame (System.Diagnostics.Stopwatch,double&,OpenTK.FrameEventArgs) <0x00107>
at OpenTK.GameWindow.DispatchUpdateAndRenderFrame (object,System.EventArgs) <0x00027>
at OpenTK.GameWindow.Run (double,double) <0x00273>
at OpenTK.GameWindow.Run (double) <0x00023>
at Microsoft.Xna.Framework.OpenTKGamePlatform.RunLoop () <0x00037>
at Microsoft.Xna.Framework.Game.Run (Microsoft.Xna.Framework.GameRunBehavior) <0x000cf>
at Microsoft.Xna.Framework.Game.Run () <0x00027>
at Solar2.Program.Main (string[]) <0x001e7>
at (wrapper runtime-invoke) <Module>.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

/games/SteamLibrary/SteamApps/common/Solar 2/lib/libmono-2.0.so.1(+0xa5848) [0xf7530848]
/games/SteamLibrary/SteamApps/common/Solar 2/lib/libmono-2.0.so.1(+0x1c910) [0xf74a7910]
[0xf777b410]
[0xd4522eb4]
[0xd4522d44]
[0xd4522bec]
[0xd45227b0]
[0xd4e09e60]
[0xd4dfd550]
[0xd4dfd004]
[0xefd2357a]
[0xefd220d8]
[0xefd21821]
[0xefd21680]
[0xefd203fc]
[0xefd20477]
[0xefd203b2]
[0xefd2038d]
[0xefd20068]
[0xefd1ff08]
[0xefd1d56c]
[0xefd1d2e4]
[0xefd1d2a8]
[0xeff3b060]
[0xeff3aea0]
[0xf53f52c0]
[0xf53f56c7]
/games/SteamLibrary/SteamApps/common/Solar 2/lib/libmono-2.0.so.1(+0x248da) [0xf74af8da]
/games/SteamLibrary/SteamApps/common/Solar 2/lib/libmono-2.0.so.1(mono_runtime_invoke+0x50) [0xf760ea20]
/games/SteamLibrary/SteamApps/common/Solar 2/lib/libmono-2.0.so.1(mono_runtime_exec_main+0xe2) [0xf7612a72]
/games/SteamLibrary/SteamApps/common/Solar 2/lib/libmono-2.0.so.1(mono_runtime_run_main+0x240) [0xf7617970]
/games/SteamLibrary/SteamApps/common/Solar 2/lib/libmono-2.0.so.1(mono_jit_exec+0x62) [0xf7507582]
/games/SteamLibrary/SteamApps/common/Solar 2/lib/libmono-2.0.so.1(mono_main+0x1844) [0xf7508e34]
./Solar2.bin.x86(main+0x259) [0x80491b3]
/lib/i386-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0xf72894d3]

Debug info from gdb:

Could not attach to process. If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user. For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Opération non permise.
No threads.

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

./solar2.sh : ligne 4 : 6050 Abandon (core dumped) ./Solar2.bin.x86 "$@"
Last edited by Etique57; Feb 3, 2013 @ 8:12am
Showing 1-6 of 6 comments
< >
Murudai  [developer] Feb 4, 2013 @ 5:29am 
Yeah, it's crashing any time it's trying to play one of the music tracks in the game.

So why it worked for 1h, and now crashes for this reason, I have no idea. Certainly nothing in the save file could cause this. I guess you could try deleting the game and reinstalling, maybe some of the music got corrupted.
Etique57 Feb 5, 2013 @ 10:23am 
I've reinstalled the game and still the same. I muted the music, just in case, but no luck either.
Murudai  [developer] Feb 5, 2013 @ 5:20pm 
Did you install anything or change anything? I mean something must have changed for the game to suddenly just not work after working just fine. Are you using a different headphones/speakers this time, or changed any other hardware?
Etique57 Feb 9, 2013 @ 1:25am 
Unfortunately not, that's the beauty of it ;)

I tried again this morning and it still crashes.

Question though: I'm not using pulseaudio but directly Alsa. Could it be part of the problem ? By the way, the music actually plays fine until it crashes.
Murudai  [developer] Feb 9, 2013 @ 5:37pm 
The 'ambient' music track that plays between the main music pieces uses a different system to play than the main music (it stores the ambient piece in memory, and it streams the main music).

Could you try removing your Alsa thing and trying then? That could help isolate this issue. Or update your audio drivers. This is the first case I've had of music crashing the game, so it's tricky to track down. It's one of those "inbuilt code fails, doesn't explain why" situations.

Last edited by Murudai; Feb 9, 2013 @ 5:38pm
Murudai  [developer] Feb 20, 2013 @ 2:32am 
Alright, I'm sure your issue is because you're not using PulseAudio. In which case go to the solar2.sh script in the Solar 2 install folder and include this line:

export SDL_AUDIODRIVER=alsa

That hopefully might work. If not, have a play around with that kind of thing. It seems to be a related issue with Linux TF2 for the same reasons, so that might help you. Another user had exactly the same issue as you, was using Alsa instead of PulseAudio, and were able to fix it with that line.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50