Solar 2

Solar 2

Solar 2 > 一般討論 > 主題細節
Heiji Hattori 2013 年 1月 12 日 @ 下午 1 時 33 分
How to enable v-sync?
I'm running Solar 2 under Linux, but I have an average of 1000 fps and my graphic card do a strange sound (it normally do this sound when I excess 300-400 fps).
So I'd like to enable v-sync but in the option I can't find how to do it. There is an hidden command?
最後修改者:Heiji Hattori; 2013 年 1月 12 日 @ 下午 1 時 37 分
< >
目前顯示第 1-3 則留言,共 3
Murudai  [開發人員] 2013 年 1月 12 日 @ 下午 10 時 01 分 
Press the ~ key (top left of keyboard under ESC). That'll bring up the debug overlay. Under 'vsync' does it say '1.0' or '0.0'? Vsync should be enabled by default, so if that value is '1.0' then it's enabled in the game, and it might be a setting on your graphics drivers that's overriding it.

To set vsync manually, make a file called 'display.txt' and put it in the main folder where is. In that display.txt file put a line exactly as:

VSync: true

That'll force enable vsync, but like I said it should be enabled by default anyway.
最後修改者:Murudai; 2013 年 1月 12 日 @ 下午 10 時 03 分
Heiji Hattori 2013 年 1月 13 日 @ 上午 1 時 28 分 
vsync is true (1.0), but I have more than 60 fps.
I tried to put the file display.txt but nothing.
When I open the game I have this warning

And I noticed that when I'm in game the value of IsFixedTimeStep is 0.0 and the fps are around 1000

But when I press Esc the fps go to 60 (vsync works) and the value of isFixedTimeStep change to 1.0

Is this normal?

EDIT:When I pressed stamp the game opened the menu, but when I'm in game the isFixedTimeStep is 0.0
最後修改者:Heiji Hattori; 2013 年 1月 13 日 @ 上午 1 時 42 分
Heiji Hattori 2013 年 1月 13 日 @ 上午 4 時 13 分 
I solved enabling from AMD Catalyst Control Center the option "Enable Tear free Desktop to reduce tearing".
Thanks murudai for your answer.
< >
目前顯示第 1-3 則留言,共 3
每頁: 15 30 50

Solar 2 > 一般討論 > 主題細節