Solar 2 > 일반 토론 > 제목 정보
[LINUX] RyuzakiKK 2013년 1월 12일 오후 1시 33분
How to enable v-sync?
I'm running Solar 2 under Linux, but I have an average of 1000 fps and my graphic card do a strange sound (it normally do this sound when I excess 300-400 fps).
So I'd like to enable v-sync but in the option I can't find how to do it. There is an hidden command?
Thanks.
[LINUX] RyuzakiKK님이 마지막으로 수정; 2013년 1월 12일 오후 1시 37분
3개 중 1-3 표시중
< >
Murudai  [개발자] 2013년 1월 12일 오후 10시 01분 
Press the ~ key (top left of keyboard under ESC). That'll bring up the debug overlay. Under 'vsync' does it say '1.0' or '0.0'? Vsync should be enabled by default, so if that value is '1.0' then it's enabled in the game, and it might be a setting on your graphics drivers that's overriding it.

To set vsync manually, make a file called 'display.txt' and put it in the main folder where solar2.sh is. In that display.txt file put a line exactly as:

VSync: true

That'll force enable vsync, but like I said it should be enabled by default anyway.
Murudai님이 마지막으로 수정; 2013년 1월 12일 오후 10시 03분
[LINUX] RyuzakiKK 2013년 1월 13일 오전 1시 28분 
vsync is true (1.0), but I have more than 60 fps.
I tried to put the file display.txt but nothing.
When I open the game I have this warning https://dl.dropbox.com/u/54456756/Screenshot%20from%202013-01-13%2010%3A13%3A56.png

And I noticed that when I'm in game the value of IsFixedTimeStep is 0.0 and the fps are around 1000 https://dl.dropbox.com/u/54456756/Screenshot%20from%202013-01-13%2010%3A17%3A33.png

But when I press Esc the fps go to 60 (vsync works) and the value of isFixedTimeStep change to 1.0 https://dl.dropbox.com/u/54456756/Screenshot%20from%202013-01-13%2010%3A17%3A21.png

Is this normal?

EDIT:When I pressed stamp the game opened the menu, but when I'm in game the isFixedTimeStep is 0.0
[LINUX] RyuzakiKK님이 마지막으로 수정; 2013년 1월 13일 오전 1시 42분
[LINUX] RyuzakiKK 2013년 1월 13일 오전 4시 13분 
I solved enabling from AMD Catalyst Control Center the option "Enable Tear free Desktop to reduce tearing".
Thanks murudai for your answer.
3개 중 1-3 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2013년 1월 12일 오후 1시 33분
게시글: 3