Solar 2 > Generelle diskusjoner > Emnedetaljer
Sir_Brizz 9. jan, 2013 @ 5:52pm
[Linux] Says I need to be running Steam, but I AM running Steam...
Topic says it all. I installed Solar 2 on Kubuntu 12.10 x64, ran it and itgives me a message that says Steam has to be running. Problem is, Steam IS running, just fine.
Viser 1-15 av 17 kommentarer
< >
Glennh 9. jan, 2013 @ 6:17pm 
I had the same error, restarting Steam as the message says fixed it for me.
Glennh 9. jan, 2013 @ 6:28pm 
I spoke too soon. The error is back and restarting does nothing.
Murudai  [utvikler] 9. jan, 2013 @ 9:15pm 
Just a weirdness of the Steam Linux Beta. Make sure it is updated to the latest version. You may need to restart your computer. Are any other Linux games having the same issue? (maybe not this exact issue, but being unable to use any Steam features or the Steam overlay). If you are still having issues, email me at jay@murudai.com and I can give you more detailed help.
Sir_Brizz 9. jan, 2013 @ 9:17pm 
Thanks, Jay. The next time I am on my laptop I will see if it decides to work, and, if not, if any other games are working.
Sist redigert av Sir_Brizz; 9. jan, 2013 @ 9:17pm
SirCampsALot 9. jan, 2013 @ 9:32pm 
Isn't Steam for Linux really only supported on Ubuntu 12.04 LTS? (store.streampowered.com/about) Not surprised you're having issues...
Sir_Brizz 10. jan, 2013 @ 8:56am 
No. They only (currently) guarantee the package dependencies are available in 12.04.
dwd 10. jan, 2013 @ 9:22am 
I have the same problem on Ubuntu 12.04
Sist redigert av dwd; 10. jan, 2013 @ 9:23am
hero1900 10. jan, 2013 @ 10:33am 
weird i dont have this issue at all on my ubuntu 12.04
dwd 10. jan, 2013 @ 10:35am 
After system reboot the problem is gone :)
Murudai  [utvikler] 10. jan, 2013 @ 5:38pm 
Okay, I just uploaded a patch to the Linux build that should help this. The issue is the Steam client being a bit slow, so I've made the game a bit more tolerant of that and giving the Steam client more time to respond. If you are still having the issue, then a restart should fix it. If it doesn't, email me at jay@murudai.com and we'll do some debugging.
Sir_Brizz 10. jan, 2013 @ 7:03pm 
I got the update, it is still not working. I will email you directly.
Murudai  [utvikler] 10. jan, 2013 @ 7:22pm 
The patch would have helped if the issue was the game, but it's certainly seeming more and more like the issue is with the Steam API unable to communicate to the Steam Client. So yeah, as I mentioned before this is because the client is still in Beta and the bugs are being worked out. I'll talk to Valve about this issue, see what they say about it.
Glennh 10. jan, 2013 @ 8:00pm 
It looks like it was indeed steam, here is a bug report https://github.com/ValveSoftware/steam-for-linux/issues/615

To fix just download and install steam_latest.deb then it should update properly.
Sir_Brizz 11. jan, 2013 @ 9:02am 
That fix did indeed work for the time being. Thanks for your help all.
vadi2 11. jan, 2013 @ 11:26am 
I had this problem as well, but when I quit steam it performed an update and upon login it and the game were cooperating.
Viser 1-15 av 17 kommentarer
< >
Per side: 15 30 50