Solar 2 > 総合掲示板 > トピックの詳細
Sir_Brizz 2013年1月9日 17時52分
[Linux] Says I need to be running Steam, but I AM running Steam...
Topic says it all. I installed Solar 2 on Kubuntu 12.10 x64, ran it and itgives me a message that says Steam has to be running. Problem is, Steam IS running, just fine.
1-15 / 17 のコメントを表示
< >
Glennh 2013年1月9日 18時17分 
I had the same error, restarting Steam as the message says fixed it for me.
Glennh 2013年1月9日 18時28分 
I spoke too soon. The error is back and restarting does nothing.
Murudai  [開発者] 2013年1月9日 21時15分 
Just a weirdness of the Steam Linux Beta. Make sure it is updated to the latest version. You may need to restart your computer. Are any other Linux games having the same issue? (maybe not this exact issue, but being unable to use any Steam features or the Steam overlay). If you are still having issues, email me at and I can give you more detailed help.
Sir_Brizz 2013年1月9日 21時17分 
Thanks, Jay. The next time I am on my laptop I will see if it decides to work, and, if not, if any other games are working.
最近の変更はSir_Brizzが行いました; 2013年1月9日 21時17分
SirCampsALot 2013年1月9日 21時32分 
Isn't Steam for Linux really only supported on Ubuntu 12.04 LTS? ( Not surprised you're having issues...
Sir_Brizz 2013年1月10日 8時56分 
No. They only (currently) guarantee the package dependencies are available in 12.04.
dwd 2013年1月10日 9時22分 
I have the same problem on Ubuntu 12.04
最近の変更はdwdが行いました; 2013年1月10日 9時23分
hero1900 2013年1月10日 10時33分 
weird i dont have this issue at all on my ubuntu 12.04
dwd 2013年1月10日 10時35分 
After system reboot the problem is gone :)
Murudai  [開発者] 2013年1月10日 17時38分 
Okay, I just uploaded a patch to the Linux build that should help this. The issue is the Steam client being a bit slow, so I've made the game a bit more tolerant of that and giving the Steam client more time to respond. If you are still having the issue, then a restart should fix it. If it doesn't, email me at and we'll do some debugging.
Sir_Brizz 2013年1月10日 19時03分 
I got the update, it is still not working. I will email you directly.
Murudai  [開発者] 2013年1月10日 19時22分 
The patch would have helped if the issue was the game, but it's certainly seeming more and more like the issue is with the Steam API unable to communicate to the Steam Client. So yeah, as I mentioned before this is because the client is still in Beta and the bugs are being worked out. I'll talk to Valve about this issue, see what they say about it.
Glennh 2013年1月10日 20時00分 
It looks like it was indeed steam, here is a bug report

To fix just download and install steam_latest.deb then it should update properly.
Sir_Brizz 2013年1月11日 9時02分 
That fix did indeed work for the time being. Thanks for your help all.
Technician 2013年1月11日 11時26分 
I had this problem as well, but when I quit steam it performed an update and upon login it and the game were cooperating.
1-15 / 17 のコメントを表示
< >
ページ毎: 15 30 50