Solar 2 > - Discussions générales > Détails du sujet
Sir_Brizz 9 jan 2013 à 17h52
[Linux] Says I need to be running Steam, but I AM running Steam...
Topic says it all. I installed Solar 2 on Kubuntu 12.10 x64, ran it and itgives me a message that says Steam has to be running. Problem is, Steam IS running, just fine.
Affichage des commentaires 1 à 15 sur 17
< >
Glennh 9 jan 2013 à 18h17 
I had the same error, restarting Steam as the message says fixed it for me.
Glennh 9 jan 2013 à 18h28 
I spoke too soon. The error is back and restarting does nothing.
Murudai  [développeur] 9 jan 2013 à 21h15 
Just a weirdness of the Steam Linux Beta. Make sure it is updated to the latest version. You may need to restart your computer. Are any other Linux games having the same issue? (maybe not this exact issue, but being unable to use any Steam features or the Steam overlay). If you are still having issues, email me at jay@murudai.com and I can give you more detailed help.
Sir_Brizz 9 jan 2013 à 21h17 
Thanks, Jay. The next time I am on my laptop I will see if it decides to work, and, if not, if any other games are working.
Dernière modification de Sir_Brizz; 9 jan 2013 à 21h17
SirCampsALot 9 jan 2013 à 21h32 
Isn't Steam for Linux really only supported on Ubuntu 12.04 LTS? (store.streampowered.com/about) Not surprised you're having issues...
Sir_Brizz 10 jan 2013 à 8h56 
No. They only (currently) guarantee the package dependencies are available in 12.04.
dwd 10 jan 2013 à 9h22 
I have the same problem on Ubuntu 12.04
Dernière modification de dwd; 10 jan 2013 à 9h23
hero1900 10 jan 2013 à 10h33 
weird i dont have this issue at all on my ubuntu 12.04
dwd 10 jan 2013 à 10h35 
After system reboot the problem is gone :)
Murudai  [développeur] 10 jan 2013 à 17h38 
Okay, I just uploaded a patch to the Linux build that should help this. The issue is the Steam client being a bit slow, so I've made the game a bit more tolerant of that and giving the Steam client more time to respond. If you are still having the issue, then a restart should fix it. If it doesn't, email me at jay@murudai.com and we'll do some debugging.
Sir_Brizz 10 jan 2013 à 19h03 
I got the update, it is still not working. I will email you directly.
Murudai  [développeur] 10 jan 2013 à 19h22 
The patch would have helped if the issue was the game, but it's certainly seeming more and more like the issue is with the Steam API unable to communicate to the Steam Client. So yeah, as I mentioned before this is because the client is still in Beta and the bugs are being worked out. I'll talk to Valve about this issue, see what they say about it.
Glennh 10 jan 2013 à 20h00 
It looks like it was indeed steam, here is a bug report https://github.com/ValveSoftware/steam-for-linux/issues/615

To fix just download and install steam_latest.deb then it should update properly.
Sir_Brizz 11 jan 2013 à 9h02 
That fix did indeed work for the time being. Thanks for your help all.
vadi2 11 jan 2013 à 11h26 
I had this problem as well, but when I quit steam it performed an update and upon login it and the game were cooperating.
Affichage des commentaires 1 à 15 sur 17
< >
Par page : 15 30 50