Solar 2 > Algemene discussies > Details van topic
Sir_Brizz 9 jan 2013 om 5:52nm
[Linux] Says I need to be running Steam, but I AM running Steam...
Topic says it all. I installed Solar 2 on Kubuntu 12.10 x64, ran it and itgives me a message that says Steam has to be running. Problem is, Steam IS running, just fine.
1-15 van 17 reacties weergegeven
< >
Glennh 9 jan 2013 om 6:17nm 
I had the same error, restarting Steam as the message says fixed it for me.
Glennh 9 jan 2013 om 6:28nm 
I spoke too soon. The error is back and restarting does nothing.
Murudai  [ontwikkelaar] 9 jan 2013 om 9:15nm 
Just a weirdness of the Steam Linux Beta. Make sure it is updated to the latest version. You may need to restart your computer. Are any other Linux games having the same issue? (maybe not this exact issue, but being unable to use any Steam features or the Steam overlay). If you are still having issues, email me at jay@murudai.com and I can give you more detailed help.
Sir_Brizz 9 jan 2013 om 9:17nm 
Thanks, Jay. The next time I am on my laptop I will see if it decides to work, and, if not, if any other games are working.
Laatst bewerkt door Sir_Brizz; 9 jan 2013 om 9:17nm
SirCampsALot 9 jan 2013 om 9:32nm 
Isn't Steam for Linux really only supported on Ubuntu 12.04 LTS? (store.streampowered.com/about) Not surprised you're having issues...
Sir_Brizz 10 jan 2013 om 8:56vm 
No. They only (currently) guarantee the package dependencies are available in 12.04.
dwd 10 jan 2013 om 9:22vm 
I have the same problem on Ubuntu 12.04
Laatst bewerkt door dwd; 10 jan 2013 om 9:23vm
hero1900 10 jan 2013 om 10:33vm 
weird i dont have this issue at all on my ubuntu 12.04
dwd 10 jan 2013 om 10:35vm 
After system reboot the problem is gone :)
Murudai  [ontwikkelaar] 10 jan 2013 om 5:38nm 
Okay, I just uploaded a patch to the Linux build that should help this. The issue is the Steam client being a bit slow, so I've made the game a bit more tolerant of that and giving the Steam client more time to respond. If you are still having the issue, then a restart should fix it. If it doesn't, email me at jay@murudai.com and we'll do some debugging.
Sir_Brizz 10 jan 2013 om 7:03nm 
I got the update, it is still not working. I will email you directly.
Murudai  [ontwikkelaar] 10 jan 2013 om 7:22nm 
The patch would have helped if the issue was the game, but it's certainly seeming more and more like the issue is with the Steam API unable to communicate to the Steam Client. So yeah, as I mentioned before this is because the client is still in Beta and the bugs are being worked out. I'll talk to Valve about this issue, see what they say about it.
Glennh 10 jan 2013 om 8:00nm 
It looks like it was indeed steam, here is a bug report https://github.com/ValveSoftware/steam-for-linux/issues/615

To fix just download and install steam_latest.deb then it should update properly.
Sir_Brizz 11 jan 2013 om 9:02vm 
That fix did indeed work for the time being. Thanks for your help all.
vadi2 11 jan 2013 om 11:26vm 
I had this problem as well, but when I quit steam it performed an update and upon login it and the game were cooperating.
1-15 van 17 reacties weergegeven
< >
Per pagina: 15 30 50