Solar 2 > General Discussions > Topic Details
Thrixy Dec 23, 2013 @ 1:27pm
Solar 2 crashes Steam when selected in library
When ever I select Solar 2 in my library it crashes my Steam client, is this because of a sudden influx of people getting the game? It also does this with The Chaos Engine.
Showing 1-15 of 19 comments
< >
The Roose is LOOSE Dec 23, 2013 @ 11:10pm 
For me, solar 2 doesn't even open. Tried EVERYTHING in the bugs & fixes thread, to no avail. If anyone could post suggestions, I'm all ears.

As for why steam itself is crashing, I have no idea :/.
Last edited by The Roose is LOOSE; Dec 23, 2013 @ 11:16pm
Thrixy Dec 24, 2013 @ 7:58am 
Yes, my game doesn't even get a chance to open before Steam crashes :(.
=170= Sven2157 Dec 24, 2013 @ 8:28am 
I believe that this game runs on the Microsoft XNA and .NET framework. Consequently so does Steam. This may explain why both take a fall. I have a thread you can try over at Eagle Dynamics forum( DCS World ). Link will follow.

If your .NET or DirectX is not up to par, this could be the issue. If this has NOTHING to do with .NET, then this will not hurt, only help your computer and other games, anyway.

Couple things:
  • The list looks longer than it is. Most of these will download in a couple seconds, regardless of internet speed, as they are only a couple hundred KBs.
  • Be sure to follow the order, they are listed in.
    • Basic rule to follow: Oldest to Newest.
    • For 64bit OS users, also mind this general rule: 32bit( x86 ) then 64bit( x64 ).
  • It will take most of you longer to read this post, than it will to complete those steps.

http://forums.eagle.ru/showpost.php?p=1654124&postcount=3

Hope that helps! ;-) Happy Holidays!

=170= Sven2157
Last edited by =170= Sven2157; Dec 24, 2013 @ 11:28am
The Roose is LOOSE Dec 24, 2013 @ 9:04am 
Thanks for the help, Sven, it's much appreciated.

Unfortunately, however, still no dice. Every game of mine works perfectly, steam works perfectly, it's just Solar 2 refuses to open. Thanks for the link to that post, it was pretty useful to download all of them, but I'm still having the issue that it will not open. No error message; I double click Solar 2 in the library, steam works for a second, and then nothing happens. Same with trying to run the .exe file in the installation directory.

Any other suggestions?
Last edited by The Roose is LOOSE; Dec 24, 2013 @ 9:05am
=170= Sven2157 Dec 24, 2013 @ 9:19am 
You could try this:
  • Click Start, then Control Panel
  • Select Administrative tools
  • Select Event Viewer
  • When that loads, look in the middle window under Summary of Administrative Events.
  • Find the ERROR Event Type, and expand it
  • Double click each of those EVENT IDs, and when the new window pops up, look for the solar 2 exe, or steam exe in the event.
  • Once you locate a couple, check to see if they are all the same, and then post one of those messages here.

They will look something like:
.NET Runtime version 4.0.30319.18408 - There was a failure initializing profiling API attach infrastructure. This process will not allow a profiler to attach. HRESULT: 0x80004005. Process ID (decimal): 7528. Message ID: [0x2509].



=170= Sven2157
Last edited by =170= Sven2157; Dec 24, 2013 @ 9:21am
The Roose is LOOSE Dec 24, 2013 @ 9:54am 
here we go,

Application: Solar2.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.IO.FileNotFoundException Stack: at Solar2.Program.Main(System.String[])
=170= Sven2157 Dec 24, 2013 @ 10:05am 
Looks like it may be an issue with the install. That error message says that it cannot find part of the program.

Have you right clicked the title in the Library, and done a 'VERIFY INTEGRITY OF GAME CACHE'?

You should also disable your Antivirus Program( s ) when you do this, so that false positives, are not being removed( which is what I suspect may have happened ).

After verification, go to the install folder( default: "C:\Program Files\Steam\SteamApps\common\Solar 2" ) right click that actual Solar2.exe and choose properties. Does it have an UNBLOCK button there, at the bottom? Click it to unblock the executable.

Then post back.

=170= Sven2157

*** EDIT ***
Just in case, to Verify the game cache, do the following:
  • Right click the title in your Library, and choose Properties
  • Click the LOCAL FILES tab.
  • Click VERIFY INTEGRITY OF GAME CACHE
Last edited by =170= Sven2157; Dec 24, 2013 @ 11:28am
The Roose is LOOSE Dec 24, 2013 @ 10:13am 
I had already verified the game cache, but did it again and nothing's changed. There's no unblock button, and the only AV I have would be anything that came with Windows. Windows Defender hasn't showed anything recent in the last month or so.

I've also completely deleted the game, and reinstalled, but no dice. : /
Last edited by The Roose is LOOSE; Dec 24, 2013 @ 10:16am
=170= Sven2157 Dec 24, 2013 @ 10:29am 
It would have to be a permission problem then. When you start Steam, do you run it as an Admin? Steam should always be 'Run as Administrator'. This is not the same as being on an administrator account. It is an added security feature that, in their infinite wisdom, Micro$oft added to Vista or later. Viruses bypass it, and the user is stuck with more headaches.

By making sure that Steam starts everytime, being run as an administrator, you ensure that the games and programs it installs, will have the correct permission to access ALL folders it needs to in you Windows environment. After all, if the program doesn't have permission to access its own files, then it would return a generic 'could not find' error; possibly like the one above.

To ensure Steam runs as an Administrator every time, perform the following:
  • Go to your main Steam directory( default: "C:\Program Files (x86)\Steam" ) and locate the Steam.exe.
  • Right click it and choose Properties.
  • Click the Compatibility tab, and at the bottom check the box for, Run this program as an administrator.
  • Click Apply, then OK.
  • Close/Exit Steam completely.
  • Restart Steam, and try re-installing/verifying the game again.
This time it should have the correct permissions to read and write its files.

Let me know!

=170= Sven2157


The Roose is LOOSE Dec 24, 2013 @ 11:11am 
I'll check that out, but I have UAC completely disabled, and I've had virtually no other issues with any steam game I've downloaded. Is there anything besides permissions that this could be?

Edited: Wiped the local data, re-downloaded, and reinstalled it. Still unable to start it. Any other ideas? For future reference, I don't think it's my system, here's what I'm using:

Windows 8.1 (x64) - (legit copy)
Ram: 8 GB 1600Mhz
CPU: AMD Phenom II x6 1090t
Radeon HD 6950 1 GB - (drivers are up-to-date as-of 12-18's 13.12 catalyst release).
Last edited by The Roose is LOOSE; Dec 24, 2013 @ 11:18am
=170= Sven2157 Dec 24, 2013 @ 11:23am 
Originally posted by Reciever80:
I'll check that out, but I have UAC completely disabled, and I've had virtually no other issues with any steam game I've downloaded. Is there anything besides permissions that this could be?

In my 25+ years with programming and computers: not really. We covered the Micro$oft programming end( .NET, DirectX and Visual C++ ), and now are covering the Micro$oft Operating System end.

That error, says that it cannot find a specific file it is looking for. This leaves 2 possibilities, really: It simply is not there, or it has no permissions to access where it is.

UAC off is just one thing; it just stops the notifications, really. Other games are not relevant because they use different file and folder structures, and write their own hierarchy/system.

By setting 'Run as Administrator', you will do 2 things:
  • 1 - You can just double click the Steam icon, and Steam will ALWAYS run as Admin.
  • 2 - You also, ensure that no matter where the game wants to install, read or write to/from, it will have the proper permissions to do so.

This may save you a huge headache latter down the road with another game someday.

There is another option you could look at, but it is a H U G E pain in the ! That is repairing the .NET framework.

I have a tendency to start with the easiest, first, and then, move to the hardest last.

=170= Sven2157
The Roose is LOOSE Dec 24, 2013 @ 11:47am 
Sorry, forgot to mention in my edit that I added the "run as admin" BEFORE i did the wipe/reinstall. So consider that already done I suppose. I'll email Jay (the maker) with the error message, and a link to the discussion to see if he has any furthur suggestions, beyond anything that you think of going forward.

Last edited by The Roose is LOOSE; Dec 24, 2013 @ 11:47am
=170= Sven2157 Dec 24, 2013 @ 11:55am 
I just noticed you have Windows 8.1. Didn't I see something somewhere about .NET or the VC++ libraries needing an independant patch for that OS and version?

Personally I think you should revert back to Windows 7. Windows 8 is a touch screen tablet OS, and M$ doesn't hide that fact either.

Anyway, we will wait to see what the Developer may add here.

I have a bit of time in on the game and think it is great. It is a nice change of pace. Hope you can get it going soon!



=170= Sven2157
The Roose is LOOSE Dec 24, 2013 @ 6:07pm 
I looked around the web, and the only patching I saw that was needed was for .NET 1.1, nowhere near 4.0.

As for windows, I like it. Once you get it setup, and everything tweaked, it's pretty cool.

The game itself looks really fun, and the fact I can't play it makes it even more tantalizing :), I'm glad to see you enjoy it so much and really appreciate the time you spent helping out.

Enjoy the holidays, and if you think of anything else that it could be, definitely comment below.
Last edited by The Roose is LOOSE; Dec 24, 2013 @ 6:08pm
boulouch Dec 26, 2013 @ 11:21pm 
No problem on my side :yay:
Showing 1-15 of 19 comments
< >
Per page: 15 30 50