sprodigy Aug 26, 2013 @ 3:33pm
Unable to create renderer on startup
Hello,

When trying to start the game, i'm met with the error, "unable to create renderer" and then a white screen. Any idea on a fix?

Showing 1-5 of 5 comments
< >
jim.buck Aug 26, 2013 @ 6:36pm 
If you get that error, it should go ahead and give you a Windows dialog box where you can change video settings. When you get that, try to use windowed mode to see if at least that works on your system. From there, we can narrow down the combination of settings that causes the renderer creation to fail.
sprodigy Aug 26, 2013 @ 9:07pm 
Thanks, i appreciate the reply! I've tried various settings here to no avail. I can get sound (but with a white windowed screen) if I choose Direct3D09. Choosing Direct3D10 results in a more verbose error: R6025 Pure function Call error

I haven't tried any of the "advanced" settings.
Last edited by sprodigy; Aug 26, 2013 @ 9:10pm
jim.buck Aug 26, 2013 @ 10:19pm 
Oh, I'm actually surprised that DX10 shows up as an option. I think we only support DX9. Hmm. So, you get a white screen even in windowed mode?? That's odd. What's your OS and graphics card? In fact, could you shoot me a dxdiag output of your system? (I don't post my company details on my clients' forums, but if you look up my profile, you can get to my company website which has a "contact us" page. You can email me the dxdiag output there.)
sprodigy Aug 27, 2013 @ 7:20am 
Jim, thanks, i'll do my best to track you down and get you that output. I'm running Win7x64 and eVGA GeForce GTX 660Ti

To reiterate: The white screen shows up, but it's a windowed square, about the size of the resolution that I expect. So, the game is "windowed" but just white. If that makes sense. There's even sound in the background.

I appreciate it! I wish the devs for "Go Home Dinosaurs" were as responsive as you. I bought the bundle and neither games are launching (similar DX errors). I've tried contacting them on their website, Facebook, Twitter, and about 3 forum posts on Steam. Sigh
Last edited by sprodigy; Aug 27, 2013 @ 7:21am
jim.buck Aug 27, 2013 @ 11:53am 
Oh, huh, I don't watch the GHD forum, since I didn't work on that, but I'm pretty vigilant about watching forums for games I worked on since I have the best means to quickly answer tech questions. :) I'll let Fire Hose Games know about it, though.

So, it sounds like you are running fullscreen but a white square is showing up on a black(?) background? How big would you say the square is? If you could take a screenshot and post it, I can at least see what resolution it's trying to run in and see if that white square if anything that looks like something I might recognize, size-wise, in the game.

If you didn't yet try windowed mode, could you try that? I suspect it would/should work, and from there maybe we can figure out what is making fullscreen not quite work. The fact that it's not working with SBS *and* GHD is interesting, though, since those games use completely different middleware for their graphics stuff (Gamebryo for SBS and OGRE for GHD). Do you have issues with other games as well?
Showing 1-5 of 5 comments
< >
Per page: 15 30 50