TsaebehT Jun 28, 2013 @ 1:59pm
NVIDIA 3D Vision
Didn't this used to trigger and play in 3D? I could swear it did, it doesn't now. I have close to an hour of logged playtime, which I really don't think would have happened if I was stuck playing in 2D.
Showing 1-12 of 12 comments
< >
motorsep  [developer] Jun 28, 2013 @ 2:44pm 
What do you mean by "3D" ? Using Nvidia 3DVision tech or in third-person view?
TsaebehT Jun 28, 2013 @ 2:47pm 
Yes, using 3D Vision ... stereoscopic 3D, not TPP.
motorsep  [developer] Jun 28, 2013 @ 2:55pm 
Could you please try typing in the console (Shift + Esc to bring it down):

vid_stereobuffer 1 , hit Enter
vid_restart , hit Enter

TsaebehT Jun 28, 2013 @ 3:10pm 
I can't at the moment, not currently on my 3D rig but I will as soon as I can and get back to you. Thanks. :)
TsaebehT Jun 29, 2013 @ 7:16pm 
Ok I tried as you suggested,

vid_stereobuffer 1 {Enter}
vid_restart {Enter}

and it didn't work, screen flickered and sterescopic 3D never triggered. I then tried vid_stereobuffer {Enter} and it returned vid_stereobuffer 0. I then tried vid_stereobuffer 1 {Enter} followed by vid_stereobuffer {Enter} and it returned vid_stereobuffer 1, I then tried quitting to see if it would stick but upon restaring the game it reset the setting back to 0.

The only thing that stood out to me in the dialog that was displayed after vid_restart was the following:

NOTE: requested 4x AA, got 0x AA
1804x1014x32x0.00hz stereo

I tried lowering the AA and then the message was requested 1x AA, got 0x AA
Last edited by TsaebehT; Jun 29, 2013 @ 7:17pm
lordhavoc Jul 6, 2013 @ 11:52pm 
Are you sure your monitor is set to 100hz or higher, and the 3DVision setup has been done? If the IR is not connected or the 3DVision setup has not been done, then it will fail as you describe. I've also had absolutely terrible luck trying to get it to talk to my 3DTV (which isn't on the approved list within the 3DVision driver apparently).

So I'd just like to be certain that this will work with OpenGL "Quad Buffer Stereo" apps - it does work here after some other issues are resolved.

While testing 3DVision here I found that the specific SDL.dll and steelstorm.exe in the current release are causing problems here with 3DVision, which we'll need to address (a crash and a gameplay bug).
TsaebehT Jul 10, 2013 @ 9:45am 
My 3D setup works fine for everything else, currently playing Dishonored with Helix's fix, played Metro: Last Light before that, and tons of games before those ... and I could swear this one was working at some point.

I don't have a monitor, I have a 65" DLP ... but it doesn't use 3DTV Play, it uses 3D Vision. It's one of the earlier Mitsubishi 3D DLPs that were supported by 3D Vision ... so I get 1080p60 3D, unlike the 3DTV Play version which is only 1080p24 or 720p60. Although I can't set the refresh rate higher than 60hz on the desktop I do get 60 FPS in-game in 3D.

What other "Quad Buffer Stereo" games are there that I could test this out on? Like I said everything else plays perfectly fine.
lordhavoc Jul 10, 2013 @ 2:17pm 
Doom 3 BFG Edition is another one.
TsaebehT Jul 17, 2013 @ 11:18am 
Ok apparently something odd is going on with my setup, I am getting 1080p60 3D through my Onkyo 3D RCVR but quad-buffered OpenGL 3D will only work when hooked up directly to my DLP.

When it's hooked up directly to the TV enabling 3D works but it's barely even noticable, are there settings for separation and convergence like in Doom 3 in 3D? As settings in the options, config file, or as console commands?
Last edited by TsaebehT; Jul 17, 2013 @ 11:19am
lordhavoc Jul 17, 2013 @ 2:40pm 
Yeah the nvidia drivers are peculiar about which hardware they'll serve up 3DTV signals to, I don't understand why - I own such a 3DTV monitor that isn't on their list and the test app works but no games do.
lordhavoc Jul 17, 2013 @ 2:40pm 
Regarding console commands, r_stereo_separation is a cvar of interest. (shift-escape to open the console)

You can also test anaglyph rendering with r_stereo_redcyan instead of vid_stereobuffer.
TsaebehT Jul 17, 2013 @ 3:36pm 
Thanks for the info. Sorry I completely forgot to mention this ... when 3D is enabled movement stutters/jitters making it unplayable. Turning is smooth as silk and unaffected by this it's just the movement and it happens whether using the 360 controller or the WASD keys.
Showing 1-12 of 12 comments
< >
Per page: 15 30 50