Adam Jun 4, 2013 @ 3:17pm
Game crashes when changing screen resolution on Linux with steam overlay enabled
Code from console:

[xcb] Unknown sequence number while appending request
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
steelstorm: ../../src/xcb_io.c:160: append_pending_request: Assertion `!xcb_xlib_unknown_seq_number' failed.
Aborted
Game removed: AppID 96200 "Steel Storm: Burning Retribution", ProcID 12660

GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce GTX 550 Ti/PCIe/SSE2/3DNOW!
GL_VERSION: 4.3.0 NVIDIA 319.23

Changing resolution works fine on HiB version, on Steam version it crashes.
Last edited by Adam; Jun 5, 2013 @ 3:24am
Showing 1-7 of 7 comments
< >
lordhavoc Jun 5, 2013 @ 12:07am 
Does it crash if you disable the Community Overlay (Properties on the game in Steam Library)?

If the error is entirely accurate, the Steam Community Overlay is not calling XInitThreads on behalf of SteelStorm, so it crashes when it tries to do threaded X11 calls.
lordhavoc Jun 5, 2013 @ 12:18am 
This is something that I could work around in SteelStorm in future, I just want to confirm whether it is a bug in SteelStorm or in Steam.
Adam Jun 5, 2013 @ 3:24am 
Originally posted by lordhavoc:
Does it crash if you disable the Community Overlay (Properties on the game in Steam Library)?

I disabled steam overlay and changing resolution works! Thank you :)
Vertigoh Aug 25, 2013 @ 11:14am 
This is the solution I was looking for, disabling the Steam in-game overlay worked for me too when adjusting the resolution.
ivan.kolmychek Sep 25, 2013 @ 7:53am 
Originally posted by Adam:
Originally posted by lordhavoc:
Does it crash if you disable the Community Overlay (Properties on the game in Steam Library)?

I disabled steam overlay and changing resolution works! Thank you :)
Thank you very much, works for me.
NoXPhasma Sep 29, 2013 @ 5:45am 
I had the same problem, disabling steam community ingame works for me too, thanks.
usermod Nov 21, 2013 @ 5:48am 
Same problem here. Same workaround. Thnx lordhavoc.

Archlinux x86_64, nvidia gt 640 with proprietary driver.
Last edited by usermod; Nov 21, 2013 @ 5:48am
Showing 1-7 of 7 comments
< >
Per page: 15 30 50