Info-High Feb 18, 2013 @ 2:47pm
Custom wide resolution
I'm wanting to use a low widescreen resolution of 960x540, but when I select it, it's not widescreen and it looks distorted. Is there a way to mark custom resolutions as widescreen?
Showing 1-6 of 6 comments
< >
motorsep  [developer] Feb 18, 2013 @ 4:47pm 
That's the video card's problem or the monitor's. The hardware doesn't want to run that res, so the game comes up screwy.

You can try forcing that resolution using -width 960 -height 540 in the launch options for the game (right click on SS:BR in your Library, Properties > Launch Options), but I am not sure if it will work. Also if the game gets screw, delete config.cfg in your userdir to reset to default settings.

May I ask why running the game at such strange resolution ?
lordhavoc Feb 18, 2013 @ 7:56pm 
In the console (shift-escape) you can try:
vid_width 960
vid_height 540
vid_conwidth 1067
vid_conheight 600

And then hit the Apply button in System (you can use the vid_restart command instead, but it likely won't save it to the config then, the menu code in Steel Storm: Burning Retribution is a bit strange like that).

Don't know if it will work though, that resolution likely isn't supported by your video drivers or monitor.
Info-High Feb 19, 2013 @ 10:47am 
@motorsep The resolution is configured and it works, and it was selectable in the game. I forgot to mention this is for the linux version. To answer your question, I am running this resolution for games because it's on a slow PC and I'm trying to get better framerate, and I can't use 4:3 resolutions because my monitor stretches them out to widescreen. The resolution is basically half the dimentions of 1920x1080.

@ Thanks for that. Those commands actually resolve the issue, in particular the vid_con* settings, vid_width and height were already set. The only thing is they must be input every time the game is started because they get reset every time. Might there be a way to auto set commands at start?
motorsep  [developer] Feb 19, 2013 @ 11:02am 
Try setting the following in the launch options:
+set vid_width 960 +set vid_height 540 +set vid_conwidth 1067 +set vid_conheight 600
Info-High Feb 19, 2013 @ 4:39pm 
It doesn't seem to work. I think +set is windows only command parameters. I tried the linux way, for example just +vid_conwidth 1067 and that didn't do anything, either. Maybe the steam linux client doesn't support that yet?
motorsep  [developer] Feb 19, 2013 @ 4:42pm 
no, those are not Windows commands. They are the engine's cmd arguments and work on any platform. I am not sure why it wouldn't work. Let's see what Lordhavoc has to say (he is the engine's author).
Showing 1-6 of 6 comments
< >
Per page: 15 30 50