Steel Storm: Burning Retribution

Steel Storm: Burning Retribution

Files will not validate
It looks like a similar problem to has resurfaced.

I recently decided to play the game again (it's been a few months) and the graphics are corrupted (no background graphics, just the individual enemies, items, etc). I tried verifying the game and files and it said the one file failed and will be reacquired. Even after that, it still fails to validate. I also tried completely removing local content and restarting Steam. Same thing.

Anyone else having problems?
< >
Affichage des commentaires 1 à 7 sur 7
TheBombOCat  [développeur] 19 déc 2012 à 11h02 
Did you try to delete ClientRegistry.blob and AppUpdateStatus.blob in the root directory of Steam? If no, try to do it.

Have you checked your disk for errors? I made a clean install of the game and it works perfect.
Also, did you check your anti-virus software? It can cause some troubles. Try disabling it when you update Steel Storm.
I deleted the two .blob files and let the Steam client run its updates. I then cleared the local content for the game and redownloaded it, but it's still saying it failed to validate. The drive checks out fine. I even tried installing the content to a completely different drive and it still failed.

Incidentally, I'm pretty sure when I first tried to play the game again recently, Steam said it needed to update the files to a newer format. Not sure if that makes a different.

Is there any way to do a lower level troubleshooting for valid game files? Maybe a SHA1 list of the files under the steelstorm directory that I can compare to my files? It's interesting that Steam says it's validating one file, yet there are hundreds of files in the steelstorm directory. Maybe that's just a weird Steam quirk.

I checked content_log.txt and found a line that seems to identify the failed file (which doesn't sound like a critical file)

[2012-12-21 00:43:14] Validation failed: "installscript.vdf" (size)

While in the game, I do get errors in the quake-style console referring to missing bsp files or some such, but I can't find a key to bring the console back up to fully read them
motorsep  [développeur] 31 déc 2012 à 14h40 
Were you able to resolve the issue?
I went ahead and gave it another try, and it seems to (mostly) be working now. I initially loaded the first training level and it looked like this:

After I moved around a bit, the background eventually filled in and it seemed to look normal.

I noticed another post where someone commented about a similar issue (black backgrounds), and I see you requested a console dump. I've put one up here:

There were a few errors towards the bottom regarding some function calls.
motorsep  [développeur] 31 déc 2012 à 20h38 
It's a bug of Nvidia video driver. Either update to 310.xx series or go to console and type:

r_shadow_shadowmapping_filterquality 1

press Enter, and you should be good to go.
I updated my NVIDIA drivers and the function call errors went away (and the graphics seem to be loading better now too).

I did notice a few other texture loading errors in the console when I started one of the levels, although they didn't seem to affect the game play. The results are below if you are interested
motorsep  [développeur] 3 jan 2013 à 0h04 
Cool stuff!

Those are nothing to worry about. Just collision shaders seems to be having a fit :)

If you look into Doom 3 BFG console (playing RoE) you will see as many warning and errors, if not more ;)
< >
Affichage des commentaires 1 à 7 sur 7
Par page : 15 30 50