xerxes727 May 24, 2013 @ 9:19pm
Game wont start up
Just purchased this game and it looks like a lot of fun, however whenever i click to play the game, nothing happens. If i try to play the map editor a new window will come up, but it wont load and then stops responding. this looks like it might have been a minor issue that an update fixed for some by looking at existing discussions on here. if anyone knows how to fix this or what is causing it i would greatly appreciate any help.
Showing 1-13 of 13 comments
< >
motorsep  [developer] May 25, 2013 @ 1:59am 
Can you please check your steamapps\common\steelstorm\gamedata\ folder and see if there are any files?
xerxes727 May 25, 2013 @ 2:52am 
Originally posted by motorsep:
Can you please check your steamapps\common\steelstorm\gamedata\ folder and see if there are any files?
there are 2 more subfolders in that folder labeled maps and models, 3 server CFG files, and then a multitude of PK3 files.
motorsep  [developer] May 25, 2013 @ 9:20am 
What PC / OS are you trying to run it on? What video drivers?

I e-mailed Steam techs to see if there are issues on their end, but most likely they will only get to it on Tuesday.
xerxes727 May 25, 2013 @ 10:55am 
im using windows 7 and NVIDIA GeForce 310m
motorsep  [developer] May 25, 2013 @ 11:22am 
Hmm.. Video drivers maybe?
xerxes727 May 25, 2013 @ 1:53pm 
not sure, i dont know how mine compare to the required drivers. i tried updating the software on them but it is up to date. would there be any way to know for sure if it is?
motorsep  [developer] May 25, 2013 @ 1:58pm 
You could checkout Darkplaces engine from SVN, build debug build and find the reason for the crash (the game uses unmodified DarkPlaces engine).

Are you using drivers from the manufacturer of your notebook or latest from NVidia's site? Manufacturer's drivers are usually way outdated.

xerxes727 May 25, 2013 @ 5:01pm 
how would i use darkplaces engine to find the bug? and i think it is still the manufacturer's drivers on my laptop, i went through the control panel to make sure they are updated, i can head to the nvidia site to install a newer version? might that solve the problem? and thanks for all the help so far!
lordhavoc May 25, 2013 @ 5:05pm 
Manufacturer-supplied drivers are often the problem unfortunately, laptop makers often do not allow the video chip maker to supply drivers (and hence desktop drivers would install but do nothing on such a laptop), but you can give it a try and download them from nvidia to see if it has driver support for that laptop.

You can try the -safe commandline option (Set Launch Options in the Properties on Steel Storm: Burning Retribution in the Steam Library) and see if it works, if so there are additional options that could be tried.
xerxes727 May 28, 2013 @ 2:28pm 
the -safe in the commandline seemed to help but didnt get it to start it up, it opened a new window which almost immediately closed and took longer for the "play game/editor" window to go away. even if i cant get it started, the support here is tremendous and appreciated.

i tried updating the drivers through nvidia and of course they arent supported. going to try to figure out the darkplaces engine to find the reason for the crash just to be sure.
motorsep  [developer] May 29, 2013 @ 8:08am 
What about any other OpenGL games (Doom 3, Doom 3 BFG, Rage, etc.) ? Do they run?
lordhavoc May 29, 2013 @ 1:55pm 
There are some workarounds but they are less-supported, put this on the commandline options (Set Launch Options in Properties):
+vid_gl20 0

If that works, then your video driver will at least let you play the game in old (Quake3-era) graphics mode.

If that doesn't work, change it to:
+vid_soft 1 +r_viewscale 0.5 +r_shadow_deferred 0

This is almost certain to work, it renders the game in software (at reduced resolution), you can get more framerate by tuning the graphics settings as usual (in particular you want shadows off, and netbook mode will boost fps at a loss in quality), there will be occasional artifacts with this as it is an unsupported mode for Steel Storm (in particular the turret shadows are white for some reason).
Ruff Daimont Jun 13, 2013 @ 4:33am 
Strange question perhaps but does your graphic card have the "optimus" technology? If so, you should try manually forcing the card to use the onboard system for certain games. It seemed to help me.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50