Jamestown
Jamestown > General Discussions > Topic Details
 This topic has been pinned, so it's probably important
westquote  [developer] Jan 17, 2013 @ 6:48am
Got Bugs?
If you are having any issues playing Jamestown, please consult this post from our support forums:

http://forums.steampowered.com/forums/showthread.php?t=1924906

If those suggested fixes do not resolve your problem, please email us at support@finalformgames.com and we'll do our best to resolve your problem. Thanks!
< >
Showing 1-14 of 14 comments
Zombirate Sep 19, 2014 @ 9:00pm 
Here's a bug for you, I literally CANNOT start a single level. As soon as the mission title text finishes showing up (after the cinematic) the game crashes to desktop. I have tried emailing your support multiple times and have recieved no answer. If you don't fix this I'll be demanding a refund. If you sell a product I EXPECT IT TO WORK.

Just FYI for those who might (rightly) suggest it's a problem with my PC, I managed to play a couple of levels before this crashing started happening. I have tried every fix under the sun and literally nothing has worked.

So ♥♥♥♥♥♥ off right now.
ZeroNebula Jan 2, 2015 @ 2:16pm 
I can't even get the game to start. I click "Play" and Steam says I'm playing it on my friends list for like two seconds, then it doesn't even open and it stops saying I'm playing a game.
Pynapil Mar 20, 2015 @ 6:06am 
I've had this bug for a few weeks now and have tried everything in my power to work out what is happening. No matter if my controller is plugged in or not, the game acts as if i were contantly pressing the A button of my controller.

Things I've tried;

Unplugging all my input devices and still have the problem (issue is not my devices)
Checking the calibration for my controller (issue is not my controller)
Launching other games or programs which would show a problem with my computer (not a problem with my computer)

The issue is exclusively with Jamestown.

Yes, I've tried varifying my install.
Yes, I've unintalled and reinstalled.

Other's have had the same issue but it doesnt seem like they've found any solution;
http://steamcommunity.com/app/94200/discussions/0/864947008437079322/
Arma_Sektos May 16, 2015 @ 10:06am 
Bug: The game runs fine, but my mouse buttons only work sporadically. Keyboard and controller are fine. This never used to happen, so what changed?
m0rd Jun 29, 2015 @ 12:50pm 
Holding down any button on my 360 controller while one of the Challenge levels are loading seems to scramble the button config and makes it impossible to fly for the duration of that attempt.
Velisu Jul 12, 2015 @ 2:34pm 
Hello, i have promblem with game too, after playng a game about one minute or two, game starting glitch, picture start blincking and shaking, and of course i cant play anymore ( It will be very good if anybody can help whits this.
Last edited by Velisu; Jul 12, 2015 @ 2:35pm
Zombirate Jul 12, 2015 @ 2:36pm 
Sounds like a GPU issue. Do the usual of updating drivers if they aren't already, and then perhaps look into artifiacting. Could be your GPU's on it's way out.
I recently updated to Mac OSX 10.11 El Capitan, after which I installed Jamestown (which I've played on this computer before, I'd uninstalled it prior to the OS update), and now the game boots for about two seconds before simply quitting. I've tried running it multiple times, with the same results each time. I understand updating a computer's OS means the game likely needs a patch so that it can keep functioning properly, but I'd appreciate it if the developers could get on this pronto.
Last edited by Captain Hack Cubit; Oct 18, 2015 @ 5:49pm
GeddoBlaster Nov 14, 2015 @ 5:49pm 
I can't even open the game, as soon as I do I get a random LUA error on pc
Fox with a cap Dec 2, 2015 @ 4:38am 
Can't open the game.

Nothing happens, no error message or anything.
Running on Windows 7, tried with and without steam controller powered on.
Don't really know where it could come from...
Fox with a cap Dec 2, 2015 @ 4:41am 
Oh, I'm dumb. Launched the game with the .exe (not through steam) and got an OpenAL-related error. Turns out it wasn't installed. Now I get an OpenGL error on startup : «Could not get raw input device name length»

Might have something to do with the fact that I'm using a Steam Controller, now.
Fox with a cap Dec 2, 2015 @ 4:45am 
Okay, it was actually a Steam Controller issue. Game now works fine.
beatnikbedlam Dec 25, 2015 @ 8:53pm 
I'm getting this error message on launch... I really want to play this and I hope that i can get it fixed

dyld: Symbol not found: _OBJC_CLASS_$_NSObject
Referenced from: ~/Library/Application Support/Steam/steamapps/common/Jamestown/Jamestown.app/Contents/MacOS/libSDL-1.2.0.dylib
Expected in: /usr/lib/libobjc.A.dylib
in ~/Library/Application Support/Steam/steamapps/common/Jamestown/Jamestown.app/Contents/MacOS/libSDL-1.2.0.dylib
I had a quite a weird one. The colour of the special weapon (Beam) is now grey instead of blue or red (1-2 players). Why or what the heck happened? Same on two different computers with two different setups.
< >
Showing 1-14 of 14 comments
Per page: 15 30 50

Jamestown > General Discussions > Topic Details