Jamestown
Jamestown > General Discussions > Topic Details
DLC not working
i have no idea how this happened, but none of the ships from gunpowder treason and plot works anymore. when i choose a ship im greeted by the four default ships. i even get an ad on the bottom of the level select, telling me i should buy the DLC! i even played the game yesterday and it worked!
Edit: i tried deleting and re-downloading the game. didnt work.
Last edited by Sigurd Balleknuser; Jul 4, 2014 @ 2:33am
< >
Showing 1-4 of 4 comments
Curio Oct 2, 2014 @ 2:27pm 
*EDIT* So I went to the DLC page in my steam client after restarting steam. There it tells me I have the DLC in my library, I clicked the "play now" button on the DLC page itself and the game started with all the DLC there. It's now working.

[Did you get this working? I'm having the same problem! i've noticed too that the leaderboards cannot connect to steam. Tried deleting contentmy library and re-installing a few times and the problem persists.]
Last edited by Curio; Oct 2, 2014 @ 2:34pm
I just ran into this problem trying to play today, I will try what you guys did.
tricosahedron Oct 10, 2014 @ 5:40am 
If you right-click on Jamestown, select properties and the DLC tab, is the box with the DLC checked?
i eventually got it to ok now, but i dont remember how. sorry guys :/
< >
Showing 1-4 of 4 comments
Per page: 15 30 50

Jamestown > General Discussions > Topic Details