S a g e ★ Aug 28, 2013 @ 6:35pm
No movies/barely any audio
So I've decided to get this game to play it with my friend on FAF. But as luck would have it, I've encountered this somewhat common problem. Surprisingly, after digging through forum archives found on google, I did not find a solution. I was hoping one of you could help me out with this problem. Here are my specs: http://puu.sh/4dwjv.png I should also mention that changing my speaker settings to stereo didn't help. Since they were already on stereo to begin with.
Showing 1-8 of 8 comments
< >
Sheppard Aug 29, 2013 @ 2:19am 
you turned stereo off or on? bcause ou have to turn it off not on
S a g e ★ Aug 29, 2013 @ 8:25am 
Even though that's contrary to what everyone else said on the matter, I've decided to try and give it a go. I'm pretty sure you cannot turn off stereo without disabling audio completely.
[izit]sykoste Aug 29, 2013 @ 8:51am 
Each application, service or process can use the audio device seperately. When you start an app that needs the audio device on win vista/8/8 that app will have its own volume control in the volume properties box. Not everyone has the ability to see this multi-process volume control by default so check your sound config in the control panel. Chances are you just have volume down on the game but not on the rest of the system or processes.

It's the same with things like skype / teamspeak. They all have there own audio controls. Try shutting down all apps/processes using sound then you can at least eliminate the culprit.

If someone by the name of Sheppard tells you to install FAF to sort your audio issues out, ignore. FAF is likely to be the cause of the audio issue. Adding more things to an underlying problem just causes more things that need to be eliminated. Does the audio work in a normal steam game without FAF/with no mods and with default game.prefs?

If it does role it back to there first then speak to Shep about the FAF issues
Last edited by [izit]sykoste; Aug 29, 2013 @ 8:52am
S a g e ★ Aug 29, 2013 @ 10:29am 
No the audio doesn't work properly while in a regular game. Maybe I should've been more clear about the problems I've been having. When I go to boot up the game I get a black screen. I'm pretty sure the intro is playing during this time, but it won't give me any video or audio. After I click a couple times, which probably skips the intro movies, the main menu loads up as well as the background video behind it. When I go to join a game however, the audio cuts in and out completely at random times. As in, it works for a few seconds then reverts to being completely silent. This happens a few times while playing the game, but for the most of the time, it's quiet.

EDIT: Okay, so it appears that the sound effects ARE playing, but they're only playing once, and then go silent.
Last edited by S a g e ★; Aug 29, 2013 @ 10:47am
[izit]sykoste Aug 29, 2013 @ 10:58am 
Did you try re-installing direct x 9? Seems like afirst port of call (try the audio cabs in the game folder (direct x))

Or you may have the video issue that has plagued this game before it even came on steam. There are many discussions and many fixes about it, just google.

Daft question but is your audio fine in supcom (not FA) or other games?

and have you deleted the game prefs file? (just in case its a wrong setting in the game or a corrupt file)
Last edited by [izit]sykoste; Aug 29, 2013 @ 11:00am
S a g e ★ Aug 29, 2013 @ 11:18am 
Haven't tried re-installing DirectX 9, will have to try that later. I think I might actually have the problem that a lot of people share, but all the fixes I found on google didn't work as said in the OP. Audio works perfectly in everything else, but I can't speak for the original supcom, as I don't have it installed right now. As for the game prefs file, I'm not sure where it's located, so I haven't deleted it yet. Right now though, I've just updated my audio drivers, will post results soon.
S a g e ★ Aug 29, 2013 @ 11:27am 
Okay, so apparently, my realtek drivers were last updated 3 years ago. The intro movies play now, and audio works fine ingame. Problem solved. Thanks for the tech support.

EDIT: I'll leave this discussion up, for future generations.
Last edited by S a g e ★; Aug 29, 2013 @ 11:29am
[izit]sykoste Aug 30, 2013 @ 3:54am 
just for future reference the game prefs file is in a folder called AppData (it is a hidden system folder so you will need to go to your user folder (usually your log in name) click 'organize' then select 'folder and search options' then click the view tab. About 7 lines down you will find 'hidden files and folders' inside there tick 'show hidden files and folders' select apply then click ok.

In your user folder you will now see a ghosted folder (all hidden folders are ghosted) open it and navigate to local, type 'g' and it will jump past all the nonsense folders. Open gas powered games. Select supreme commander forged alliance and you will see a cache folder and a file called game.prefs.

To reset all game settings, or to remove a corrupt file (solves most no start issues) just delete this file. When the game re-boots it will generate a new file and go back to default. You will have to set your game up as you like it again like graphics settings, but it solves most problems with unexplained crashes.
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Aug 28, 2013 @ 6:35pm
Posts: 8