Pulec Feb 20, 2013 @ 1:12pm
Unable to launch FA, SupCom runs but fails very soon
My specs are:
ASUS P8Z77-V PRO
i5 3570k
2x8gb DDR3 @ 1600mhz
AMD Radeon HD 7950 with catalyst 13.1 (tried to go back to 12.10, but everything was the same)
Windows 7 64 bit

I was playing Supreme Commander back when I had no graphics card, just on HD 4000, there were some graphic issues, but it ran quite fine. I am not sure how it was with original Supreme Commander, but Forged Alliance and Forged Alliance Forever (FAF) worked fine.

Now with AMD Radeon HD 7950 I tried to game with run with FAF first, lobby was ok, then I wanted to start the game, In transit screen, some sounds and then error log.

After few tries with FAF, different games, running tutorials and etc, it was still the same. I tried to run game via Steam normally, nothinga happened, the exe file in process manager but closed after few seconds.

Deleting the preference files in appdata made no difference.
Supreme Commander started fine at first, but when creating new profile, the screen started flickering and I had to kill the process. After running it again, I got in the menu, started skirmish, but after 10s the screen was flickering again.
Next time running SupCom it just instantly crashes with error log, need to delete configs again.

Downgrading drivers to 12.10 did not change anything. I could switch to force HD 4000 in bios somehow, but I don't want do that.

Of course I searched in forums, I don't use UAC and I tried compability settings, found some fix to disable spdif playing device, still the same. Lucida Virtu enabled or disabled, no change. Maybe different DirectX version could do some mess. Like in Homeworld, which needed DirectX 7 and system just assumed that DirectX 11 is fine for it.
I don't feel like reinstaling OS because of it, but I would like to try this on Xubuntu via Wine, too bad there is no FAF on Linux. :-/

Here are dump files, logs, prefs and dx diag
https://www.dropbox.com/sh/q1le0fod8eg462m/cd7sphudGZ
Last edited by Pulec; Feb 21, 2013 @ 12:06am
Showing 1-15 of 17 comments
< >
a new machine Mar 14, 2013 @ 6:19am 
to pulec i see you din't have many reactions i don't know if you had any luck sofar but i have a problem of my own wich i cant get of my system even after a format but if you still havent had any luck then try the Gas Powererd Forums and sometimes i got lucky with getting a driverpack from guru3d.com have some fun ..... nice to know you also play homeworld
Pulec Mar 14, 2013 @ 1:59pm 
Yeah, I am getting ready to play it in VirtualBox, but I will rather wait for Planetary Annihilation :-) Yeah Homeworld is great, too bad about the rights, Hardware from ex-relic will be interesting.
Pulec Mar 14, 2013 @ 6:02pm 
BTW the issue has been posted with some reaction here http://forums.gaspowered.com/viewtopic.php?f=10&t=61903

I have given up trying to make SupCom work.
Sheppard Mar 16, 2013 @ 8:15am 
you should ask here, http://www.faforever.com/forums/viewforum.php?f=3 , FAF has an inbuild debugger which can help to solve problems
Pulec Jul 11, 2013 @ 9:48am 
Somehow I got it working, SupCom didn't crash yet but there is still some proble with FA, FAF works good though. Probably something with graphic drivers radeon vs intel ones, I upgraded just radeon ones to 13.04. Not sure what was the problem before, I had a hunch it was DirectX related.
U.F.F Chariot Jul 12, 2013 @ 9:45am 
When I try to launch supcom FA it just says application had to shut down can anyone help?
U.F.F Chariot Jul 12, 2013 @ 1:03pm 
What is FAF and how can I get it?
Pulec Jul 12, 2013 @ 3:06pm 
Simply something like steamworks for Supreme Commander, only there is no Steam in it, lots of good features.

http://www.faforever.com/

Just install, register and play and get ranked, learn first.
U.F.F Chariot Jul 13, 2013 @ 2:28am 
So ths will make my supcom FA work?
Pulec Jul 13, 2013 @ 2:32am 
Originally posted by Skull Reaper22X:
So ths will make my supcom FA work?
LoL, probably not, it just runs FA different way then the game does. Who knows what your problem is, drivers most likely, try to go to FAF forum (link few post higher) and try to find a solution there.

Anyway you gave us very little info about your problem is hard to give any advice. Try searching there first and then write details about your problem.
Sheppard Jul 13, 2013 @ 4:31am 
Originally posted by Skull Reaper22X:
So ths will make my supcom FA work?
maybe, maybe not
90% of the FA problems are sloved by
- running FA as admin
- running FA through FAF
- uninstalling google desktop

so yes it might make your FA run, but maybe it might not, for me, a programm crashing after a few minutes/seconds sounds more like a driver/hardware problem rather than a softwareproblem (i know that drivers are software i mean a problem of the game) so maybe you are one of that 10% that do have another problem

but as i said at the very beginning, you should ask in the GPG/FAF forums because there are way more (more numerous) competent people that might be able to help you
Last edited by Sheppard; Jul 13, 2013 @ 4:32am
Seven7 Jul 13, 2013 @ 4:36am 
99% of the FA problems are sloved by
- runnning FA in "Windows XP SP3" compatible mode
Sheppard Jul 13, 2013 @ 4:44am 
Originally posted by Seven7:
99% of the FA problems are sloved by
- runnning FA in "Windows XP SP3" compatible mode
no but you can add it to the 90% list
U.F.F Chariot Jul 13, 2013 @ 9:26am 
How do I delete Google desktop (I feel like a noob)
U.F.F Chariot Jul 13, 2013 @ 9:28am 
This may help. My supcom 1 does not work if I try to open it with steam or anything else but it will only work if I put the disk in my PC
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: Feb 20, 2013 @ 1:12pm
Posts: 17