Supreme Commander: Forged Alliance

Direfox Mar 17, 2013 @ 8:24am
"Unable to create Direct3D" Anyone know how to fix this?
I just bought the game, since I used to play on the console and I loved it. But, I cannot launch it since this error keeps on poppin up. I updated drivers and everything, anyone have any ways on how to fix it?
Showing 1-15 of 15 comments
< >
a new machine Mar 17, 2013 @ 8:59am 
have you installed direcxtx?
Direfox Mar 17, 2013 @ 8:59am 
Yes
brettmurguia Mar 17, 2013 @ 5:35pm 
im having the same problem :(
UZI SUICIDE Mar 19, 2013 @ 12:02pm 
Many answers on google including manually adjusting the monitor in the game settings to the correct resolution... otherwise this seems the most credible, from Microsoft.

http://answers.microsoft.com/en-us/windows/forum/windows_7-gaming/unable-to-load-supreme-commander-error-unable-to/7fa779ea-bc2f-44b0-affe-a99d30ad1edf?msgId=d18f5ef4-aeab-4933-b68e-505657604f06
UZI SUICIDE Mar 19, 2013 @ 1:12pm 
Also, have you checked your hardware will run the game (CPU, Graphics card, and Ram)
Direfox Mar 21, 2013 @ 8:19pm 
Found out why, my graphics card can't support 3D Shader models, planning to get a new graphics card. Thanks for the help anyway.
Last edited by Direfox; Mar 21, 2013 @ 8:19pm
Shinzok Mar 22, 2013 @ 3:21am 
depending on your current system specs, i would get a pretty decent graphics card , AND make sure it will fit in your computer before getting the first one found.
Direfox Mar 22, 2013 @ 12:50pm 
Ok.
SirBoss Apr 25, 2013 @ 2:23pm 
I have nVidia GT630, i7-3770, 8GB RAM.... changed my screen res to 1920 x 1080. Updated drives.... anyone got any ideas????
SirBoss Apr 25, 2013 @ 2:24pm 
oh and 2GB dedicated graphics
Direfox Apr 25, 2013 @ 3:32pm 
I have a new graphics card, a GTX 650. It works fine now, thanks anyways. :D
Kazic Jun 14 @ 5:32pm 
"Unable to create Direct3D" for Supreme Commander and Supreme Commander: Forged Alliance fix!

For those that installed these games in steam, tried to launch and received Unable to create Direct3D after clean installation.

Step 1: open steam folder where you have it installed. mine is games folder because I don't like it in program files

C\games\steam\steamapps\common\supremecommander\bin

open bin and right click SupremeCommander.exe and troubleshoot compatibility don't click try recommended settings. click on troubleshoot program instead check off I dont see my problem listed select operating system (I run windows 8.1 but chose windows8) click next and test the program it should launch in windowed mode then go to options in game and adjust resolution, mine is 1920x1080 at 60hz and hit apply.

Step 2: you will need to edit game.prefs default resolution in appdata which is a hidden folder


C\Users\"user name"\appdata\Local\GasPoweredGames\SupremeCommander

open game.prefs in notepad and scroll down and change default resolution to your native resolution mine is 1920,1080,60' and save.

hope this helps I was searching for hours on end for a fix, updating drivers, installing directx9 ect with no results

Launch and Destroy!


rodeo11 Jul 4 @ 10:45am 
kazic i have that problemn but i have windows 7 so how am i going to salve that because i don't want windows 8 can any one help me?
Ksiborg Jul 19 @ 11:00pm 
Kazic, it doesn't work.
Last edited by Ksiborg; Jul 19 @ 11:00pm
Ceejay Jul 21 @ 8:10am 
Originally posted by rodeo11:
kazic i have that problemn but i have windows 7 so how am i going to salve that because i don't want windows 8 can any one help me?


Originally posted by Ksiborg:
Kazic, it doesn't work.

Are you two sure your computers are up to it, as the op showed sometimes it can be down to old graphic cards.
Showing 1-15 of 15 comments
< >
Per page: 15 30 50