Bluebadge11 Mar 29 @ 2:15pm
After 22 hours of play, clicking "play" gives no response
So I've been playing SupCom FA for 22 hours on Steam and several more on FAF (non steam online service). I haven't played for a long while, but I wanted to get back into it. Unfortuanetly for me now when I click "play" Steam gives me nothing. Occasionally I've had the screen with the deals pop up that you normally see when you quit any steam app but it just seems to have stopped working. I put this in the SupCom forum because this is the only game it's happened too.
Showing 1-13 of 13 comments
< >
Magron Mar 29 @ 2:23pm 
try:


Right Click the game (SCFA) in your game library
Click on Properties
Go to the Local Files tab
Click Verify Integrity of Game Cache
Prepare to wait 10-15 minutes while it checks.
Bluebadge11 Mar 29 @ 2:58pm 
Tried it... Said it was alright. Specifically "all files succesfully validated"
Let me mention I've got the original SupCom and that was working. I just checked and played a round.
Last edited by Bluebadge11; Mar 29 @ 3:05pm
Nonna Mar 29 @ 3:38pm 
I got the same problem; i think it is sadly unfixable.
Bluebadge11 Mar 29 @ 4:24pm 
Originally posted by Jew Trade:
I got the same problem; i think it is sadly unfixable.
Yeah well I'm not ok with it if something I payed for on Steam just didn't feel like working.
Bluebadge11 Mar 29 @ 4:30pm 
Okay I made some progress. It starts but now it quickly dissapears and just changes the resolution to prepare for launch.
Last edited by Bluebadge11; Mar 29 @ 4:32pm
Bluebadge11 Mar 29 @ 7:19pm 
I literally reinstalled Steam completely and re-downloaded fa and it still won't work. Also I got Steam to give me an error message. So my issue is "Failed to start game - unknown error"
Last edited by Bluebadge11; Mar 30 @ 7:05am
Magron Mar 30 @ 9:40am 
update drivers...try different game settings. so many people are playing this game off steam without problems it's almost assuredly a local problem you're experiencing. I know 'it's your computer' is the last thing you want to hear but it's usually the reason.
Bluebadge11 Mar 30 @ 12:52pm 
Originally posted by Magron:
update drivers...try different game settings. so many people are playing this game off steam without problems it's almost assuredly a local problem you're experiencing. I know 'it's your computer' is the last thing you want to hear but it's usually the reason.
Only reason I don't think this is because it worked perfectly and I never changed anything besides the OS from Windows 8 to 8.1. That is possibly the issue, but I doubt it so for now I guess will just use FAF.
Last edited by Bluebadge11; Mar 30 @ 12:52pm
Magron Mar 30 @ 1:27pm 
Originally posted by Bluebadge11:
Originally posted by Magron:
update drivers...try different game settings. so many people are playing this game off steam without problems it's almost assuredly a local problem you're experiencing. I know 'it's your computer' is the last thing you want to hear but it's usually the reason.
Only reason I don't think this is because it worked perfectly and I never changed anything besides the OS from Windows 8 to 8.1. That is possibly the issue, but I doubt it so for now I guess will just use FAF.

have you tried fiddling with the compatability settings?
Bluebadge11 Mar 31 @ 12:23pm 
Originally posted by Magron:
Originally posted by Bluebadge11:
Only reason I don't think this is because it worked perfectly and I never changed anything besides the OS from Windows 8 to 8.1. That is possibly the issue, but I doubt it so for now I guess will just use FAF.

have you tried fiddling with the compatability settings?
Like run in windows xp compatibility mode and run as admin and things like that? Yeah.
Well anyway I figured out how to access singleplayer through FAF and it works so I guess I can just deal with it.
Darkshadow89 Apr 6 @ 3:17pm 
I had something similar to this happen to me a while back on windows 7. This will sound strange but the way I fixed the problem was right clicking the game and selecting "troubleshoot compatibility". Just let it load and then click "try recommended settings". For some reason this worked and manually changing the compatibility settings did not.
Fox Apr 11 @ 3:16pm 
ive suddenly got this after 120 hours of playing
{K.N.G} Zigg May 7 @ 12:03pm 
i had the same problem on my old laptop after i got a windows 8 laptop it worked fine. this is the only fix i have found for it other than just searching the internet for days idk
Showing 1-13 of 13 comments
< >
Per page: 15 30 50