A.R.E.S. > - Discussions générales > Détails du sujet
ThreeSon 19 mai 2013 à 9h12
Any GTX 680 or i7 3770 owners that also have ARES?
EDIT: Solution found. If your computer uses hardware that greatly exceeds the system requirements of a particular 2D game, and that game is running with both of the following symptoms, please point the developer of that game to this thread and see if they can implement a similar fix:

- Frame rate is at sustained, non-fluctuating 42 FPS, including while viewing logos and at the main menu (for 60 Hz monitor - might be faster, but similarly crippled, for displays with a higher native refresh rate).

- One or more CPU cores is locked at 100% load while the game is in focus (open the task manager and check the performance tab to verify).
Dernière modification de ThreeSon; 14 juil à 21h14
Affichage des commentaires 1 à 15 sur 39
< >
Master Race Member #42 8 juin 2013 à 7h51 
I can try all out in the next few days. :)
ThreeSon 8 juin 2013 à 8h06 
Hey thanks very much.
Zamaro 13 juin 2013 à 11h04 
a GTX680 is not nearly enough to run this type of game... No, to be serious, it's maybe a problem with optimus (the game may be running on the integrated graphic thingy)... Go check that through the NVidia configuration panel!
ThreeSon 13 juin 2013 à 16h55 
a GTX680 is not nearly enough to run this type of game... No, to be serious, it's maybe a problem with optimus (the game may be running on the integrated graphic thingy)... Go check that through the NVidia configuration panel!

I'm looking through the nVidia control panel, but I can't find anything regarding Optimus in either the 3D Program settings or the rest of the control panel. Can you tell me where I need to look to find it?
GAX-777-RUS 14 juin 2013 à 0h12 
Upgrade to DirectX and software and upgrade the video card driver
ThreeSon 14 juin 2013 à 2h20 
GAX-777-RUS a écrit :
Upgrade to DirectX and software and upgrade the video card driver

Everything is fully updated. I addressed the problem to nVidia long ago, but they have not responded and each new driver fails to fix the problem, including the latest one (320.18).
Zamaro 14 juin 2013 à 2h40 
ThreeSon a écrit :
a GTX680 is not nearly enough to run this type of game... No, to be serious, it's maybe a problem with optimus (the game may be running on the integrated graphic thingy)... Go check that through the NVidia configuration panel!

I'm looking through the nVidia control panel, but I can't find anything regarding Optimus in either the 3D Program settings or the rest of the control panel. Can you tell me where I need to look to find it?

I'm french, so the names I'm gonna give you in the control panel may be a bit different... So, first, you go in the 3D Program Settings, then, you click on the "program parameters" tab. Then, click "add", find your game in the steam folder (ares.exe). And finally check with what graphical processeur is running the game. If the game is running with the integrated chip, change it to the "processor NVIDIA high performances", or something like that... I had to do that in order to stop lags too.
ThreeSon 14 juin 2013 à 3h30 

I'm french, so the names I'm gonna give you in the control panel may be a bit different... So, first, you go in the 3D Program Settings, then, you click on the "program parameters" tab. Then, click "add", find your game in the steam folder (ares.exe). And finally check with what graphical processeur is running the game. If the game is running with the integrated chip, change it to the "processor NVIDIA high performances", or something like that... I had to do that in order to stop lags too.

Ok, I know the section you are talking about. However I do not have integrated graphics on my machine, or none that I know of anyway (ASUS P8Z77-I DELUXE and i3770K). When I select the ARES.exe in the 3D Settings tab, here are all of the options I have:

Ambient Occlusion
Anisotropic filtering
Antialiasing - FXAA
Antialiasing - Gamma correction
Antialiasing - Mode
Antialiasing - Setting
Antialiasing - Transparency
CUDA - GPUs
Maximum pre-rendered frames
Multi-display/mixed-GPU acceleration
Power management mode
Texture filtering - Anisotropic sample optimization
Texture filtering - Negative LOD bias
Texture filtering - Quality
Texture filtering - Trilinear optimization
Threaded optimization
Triple buffering
Vertical Sync

For CUDA - GPUs, the only option available is the 680 card, so I'm fairly certain that is not causing the problem.

Among the other options, I have tried forcing Vsync, Triple buffering, and Threaded optimization both on and off, as well as switching Power management from 'adaptive' to 'prefer maximum performance', and trying every available option for 'multi-display/mixed-GPU acceleration' and 'maximum pre-rendered frames'. None of the changes had any effect, and I can't imagine any of the other options would do anything.

Appreciate the help, though. Are there any other possibilities you can think of?
ThreeSon 14 juin 2013 à 3h31 
Librom a écrit :
I can try all out in the next few days. :)

Librom, were you able to get a chance to test this out yourself?
Bulldogs 15 juin 2013 à 5h27 
Change your default nvidia settings as follows:

Power management mode - maximuim performance

Multi-display/mixed-GPU acceleration - SIngle Display mode

Triple buffering - off / disabled

Vertical Sync - off / disabled

Texture filtering - High Quality


Also in windows power management / scheme options in control panel make sure the power managerment is on high performance not balanced or energy saver


And also install this http://www.microsoft.com/en-us/download/details.aspx?id=8109

Direct X runtime (Yes i know you have DX11 and 10 but the base direct X 9 runtime are still a seperate layer and required for many games still and the default DX 9 in win 7 is way out of date compared to that link above).
Dernière modification de Bulldogs; 15 juin 2013 à 5h29
ThreeSon 15 juin 2013 à 9h43 
Change your default nvidia settings as follows:

Power management mode - maximuim performance

Multi-display/mixed-GPU acceleration - SIngle Display mode

Triple buffering - off / disabled

Vertical Sync - off / disabled

Texture filtering - High Quality


Also in windows power management / scheme options in control panel make sure the power managerment is on high performance not balanced or energy saver


And also install this http://www.microsoft.com/en-us/download/details.aspx?id=8109

Direct X runtime (Yes i know you have DX11 and 10 but the base direct X 9 runtime are still a seperate layer and required for many games still and the default DX 9 in win 7 is way out of date compared to that link above).

Thanks for the suggestion. I set all the options as you listed, changed my power management to high performance, and installed the DirectX runtimes, but no change. The framerate chugs right from the opening logos.

For more details on this problem, check this post I made in the nVidia forums: https://forums.geforce.com/default/topic/523833/

(the low framerate only happens in fullscreen, or when alt-tabbing from windowed mode)
Doc WiZ 17 juin 2013 à 11h01 
EVA GTX 680 Superclocked, I5 3570k Overclocked to 4.6ghz and 16gb 1600mhz ddr3 ram. Problem for me is too many frames.
RiO 17 juin 2013 à 15h23 
Shot in the dark: Have you tried forcing adaptive vsync?

I ask because if the game is indeed rendering too many frames (as Mr. Derpacus is hinting at), it could overwhelm any vsync operation and cause continuous 'misses', leading to the crazy reduced frame rate.

Forcing adaptive vsync may cause the game to act more well-behaved as adaptive vsync was created exactly to combat mismatches between FPS and monitor refresh rate.

(If this is the case, then this whole problem would likely not be nVidia's fault, but the developer's; they would probably have failed to provide proper FPS capping.)
ThreeSon 17 juin 2013 à 16h47 
RiO a écrit :
Shot in the dark: Have you tried forcing adaptive vsync?

I ask because if the game is indeed rendering too many frames (as Mr. Derpacus is hinting at), it could overwhelm any vsync operation and cause continuous 'misses', leading to the crazy reduced frame rate.

Forcing adaptive vsync may cause the game to act more well-behaved as adaptive vsync was created exactly to combat mismatches between FPS and monitor refresh rate.

(If this is the case, then this whole problem would likely not be nVidia's fault, but the developer's; they would probably have failed to provide proper FPS capping.)

Interesting. I tried forcing adaptive sync and it did not improve the situation at all. However, just for the hell of it I gave adaptive-half refresh a try, and it actually improved the frame rate a little, though still not enough to really be playable. I'd say the framerate before was about 15 FPS, and with the adaptive-half refresh enabled it goes up to about 25 (doesn't feel like a full 30 to me, even though that is half my monitor's refresh of 60).

Does that info give you additional insight at all?
ThreeSon 17 juin 2013 à 16h49 
Mr. Derpacus a écrit :
EVA GTX 680 Superclocked, I5 3570k Overclocked to 4.6ghz and 16gb 1600mhz ddr3 ram. Problem for me is too many frames.

Could you clarify that? Are you saying you own ARES and do not have any framerate issues on your machine?
Affichage des commentaires 1 à 15 sur 39
< >
Par page : 15 30 50