LaGGer Jun 8, 2013 @ 10:43am
Disabling Npc ragdolls
Anyone know how to do this? Many thanks!
Showing 1-13 of 13 comments
< >
Irv Jun 12, 2013 @ 6:14am 
Hi, it’s not possible to disable ragdolls.

Why do you want to do that?
LaGGer Jun 12, 2013 @ 9:09am 
Originally posted by Irv:
Hi, it’s not possible to disable ragdolls.

Why do you want to do that?
While trying to look for items I have set the respawn rates extremely fast and after a while of combat the ragdolls/corpses start to effect gameplay and cause lag, then I have to reload the map which gets somewhat annoying. Is there at least a way to clear ragdolls/corpses? Thanks!
Dj Otacon Jun 12, 2013 @ 3:36pm 
You have a reinforce parameter on the game settings. I think this is the ratio of the respawn enemies. To best farming reduce de IA to the lower settings and increase de ratio of reinforcements.
LaGGer Jun 12, 2013 @ 5:28pm 
Originally posted by Dj Otacon:
You have a reinforce parameter on the game settings. I think this is the ratio of the respawn enemies. To best farming reduce de IA to the lower settings and increase de ratio of reinforcements.
Yes this would help but I would still like to farm at a fast rate. Anyone have any ideas?
Irv Jun 13, 2013 @ 7:45am 
At our knowledge there is no option to set the corpses despawn timer.

Do you notice this lag issue with any kind of enemy? What’s your computer specs?
LaGGer Jun 13, 2013 @ 9:03am 
Originally posted by Irv:
At our knowledge there is no option to set the corpses despawn timer.

Do you notice this lag issue with any kind of enemy? What’s your computer specs?
I am killing lots of bandits. Spec: Processor Intel(R) Core(TM) i7 CPU 870 @ 2.93GHz, 2934 Mhz, 4 Core(s), 8 Logical Processor(s)

Ram: Installed Physical Memory (RAM) 8.00 GB

Windows

Graphics: GTX 670
Irv Jun 14, 2013 @ 7:55am 
Can you try to disable the Ultra Violence setting to see if the game runs smoother?

Can you check if your graphic drivers are up to date?
LaGGer Jun 14, 2013 @ 9:20am 
Game runs fine normally playing, and I always keep my drivers up to date, they automatically update the day updates are released, but I lag after I have killed around 100 of them.

Ill try what you said with the Ultra Violence setting.
Last edited by LaGGer; Jun 14, 2013 @ 9:21am
Stu Jun 25, 2013 @ 5:34am 
I have just had a try and I wasn’t able to duplicate the issue.

The max numbers of ragdolls at the same time are limited and playing in invasion shouldn’t change anything.

Do you experiment this on a map you did or on a map from the game? If it is from the game do you experiment the issue on any map or on a specific one?

Do you see the same with other characters than bandits?

Did you change anything in a config file or through a command line, like modifying the number of decals visible or something else?
LaGGer Jun 25, 2013 @ 1:59pm 
This is playing on a map that my brother had made that is not yet finished.
I have not changed anything withen the config file or command line.
Last edited by LaGGer; Jun 25, 2013 @ 2:00pm
Worlom Jun 25, 2013 @ 4:40pm 
He probably forgot to limit number of bodies and drops.
Stu Jun 27, 2013 @ 1:43am 
Yes, I assume it begin to lag once there are too much ammo boxes dropped on the level.

Each ammo box is a physical object and it consumes some resources. So, you have to add an entity on the level to limit the number of ammo boxes.

Have a look on the game_weapon_manager entity. It is described on page 7 in the FGD guidelines.
LaGGer Jun 27, 2013 @ 2:35am 
Originally posted by Stu:
Yes, I assume it begin to lag once there are too much ammo boxes dropped on the level.

Each ammo box is a physical object and it consumes some resources. So, you have to add an entity on the level to limit the number of ammo boxes.

Have a look on the game_weapon_manager entity. It is described on page 7 in the FGD guidelines.
I will look into this, thank you very much for the help.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Jun 8, 2013 @ 10:43am
Posts: 13