Flowmad 2 août 2013 à 8h55
How to play Master Levels in GZdoom with Brutal Doom?
I bought the Classic Doom collection and got all the other versions to run in Brutal Doom with GZdoom and DoomMetalVol3 and it is glorious!>:D But the Master Levels for Doom 2 is the only one i dont get to work with it, because the WAD files are seperated into the maps so there are many of them. When i put all of them into the GZdoom folder, they are not shown in the GZdoom menu like the other games. Got anyone a solution for this?
Dernière modification de Flowmad; 2 août 2013 à 8h56
Affichage des commentaires 1 à 15 sur 16
< >
videogames10 2 août 2013 à 23h31 
I'm using ZDoom and I ran into the same problem with the original Master Level WADS (haven't tried Brutal Doom yet). I finally found a menu app that worked without requiring an editor - "Unofficial Master Levels for Doom 2 Patch" from the following link:


Just copy the 20 Master Level WAD files into a folder called "maps" on your desktop; download the app, run it and create a new folder called "Master" (default name). The Master file will be created within the app's folder. Just drag the Masters file over ZDoom.exe or GZDoom.exe and select Doom II from the menu. You should now see a new menu within Doom II with two choices - one of them being the Master Levels.

If you need a more detailed step-by-step procedure, I'll post it here when I have the time. Note that the app gives you several choices regarding the order in which you would like to play the Master Level WAD files. When making a selection from the drop-down box, keep in mind that the TEETH level contains another secret level. I selected the first option. Will see how it works.

Note: The dosbox app within the Steam Master Levels folder is broken. If you want to play the Master Levels without ZDoom or GZDoom, then you'll need to copy and paste the dosbox app from one of the other Doom games (Ultimate Doom, Doom II, Final Doom) into the Master Levels folder and overwrite the existing dosbox file. The game should work fine now; although, I don't know why you would want to play without ZDoom or GZDoom. If the menu app described above doesn't work with GZDoom (although it should), the link for ZDoom is below.

Dernière modification de videogames10; 3 août 2013 à 0h04
Flowmad 3 août 2013 à 2h54 
Thanks allot for the help! :) But unfortunately it doesn't seem to work, i did everything you said. I kept the first choices of the patcher like Map order: Doom Classic (PSN) w/ Secret Exit Restored and Music: Doom Classic (Doom 2 Order), patched the wads successfully into one master.wad file and saved it on the desktop. Then i copied the file into the GZdoom folder and started GZdoom and selected Doom 2, but the game starts just like usual and there is nothing found about the master levels. I started a new campaign, but it just starts the original one. I downloaded Zdoom and there is the same problem, maybe i overlooked something or i selected the wrong patch options? The master file 3,36 MB big btw, but i don't think thats the problem.
videogames10 3 août 2013 à 11h25 
FudgeYaw.aut a écrit :
Then i copied the file into the GZdoom folder and started GZdoom and selected Doom 2, but the game starts just like usual and there is nothing found about the master levels.

Unfortunately, you can't just put the Master file in the ZDoom/GZDoom folder. Wish that were the case, though. Try left-clicking on the Master file that was created within the menu app folder and drag it on top of the ZDoom.exe or GZDoom.exe file. Now click on Doom II and see if that works. If you're using the original WAD files, the menu will look like the picture in the link below:


The menu app may not work with Brutal Doom, though.
Flowmad 3 août 2013 à 11h50 
OH ok, now it works! But if i start it that way, then i can't run it with Brutal Doom since i have to start it the same way as well, thats kind of a shame. At least i can play them GZdoom now, thats something. Thanks allot man! :)
Wolf Lohuis 5 août 2013 à 3h18 
If i run zdoom i cannot see my savegames :( is there any option to get the steam cloud saves in there? and is there any option to let steam know that i'm playing that game when i run zdoom?
Flowmad 5 août 2013 à 3h53 
Wolf Lohuis a écrit :
If i run zdoom i cannot see my savegames :( is there any option to get the steam cloud saves in there? and is there any option to let steam know that i'm playing that game when i run zdoom?
No sorry, i guess there is no way to get these savefiles from the original to Zdoom, because Zdoom is not (except for the WAD files) depending on the original dos game and is completely different. You can actually uninstall the original games from Steam after you copied the WAD files into Zdoom and you can still play it. Unfortinately you have to beginn a new game i guess, but don't take my word, i'm a noob myself in Classic Doom modding, maybe Google helps.
Mok 13 août 2013 à 5h04 
Copy all the files from your modded Doom 2 base folder, paste them into the Master Levels of Doom folder and overwrite all.

Put the Master Levels wad you created from the link above in the skins folder.
It will now be a selectable chapter, works with Brutal Doom and the Steam overlay.

Edit: I use zandronum, I tried with gzdoom and while it works, I could only get brutal doom running by dropping the .pk3 on the gzdoom.exe
But then how would I get my other mods running too?

It looks like it needs to be added to the .ini, which is the correct way for zandronum too. But I don't really understand the format it is meant to read as.

Dernière modification de Mok; 13 août 2013 à 5h53
Nurdle 8 sept 2013 à 18h34 
For those wondering the solution is pretty simple.

Fist off create your master.wad using Blzut3's patcher as mentioned above.
Now you have created the master.wad here are the instructions for GZdoom and Zandronum.

Extract GZdoom to where you want it and run the program once. This will create an .ini file named after the windows account your on. Example mine is called "zdoom-Nurdle.ini".

Open the .ini with notepad\notepad++ etc and scroll down to the section...


Read the text before this line to better understanding how the autoload works.

Now underneath the [Doom.Autoload] section you have to enter the exact path and filename you want to autoload. You need to remember that each new file goes onto a new line and must be preceeded by "path=" without quotes.

Here is what my .ini looks like after I have edited it.

As you can see i put all my external files into a folder called "wads" and placed all my files into it. Yours can be setup however you need it to be but you must use the full path and filename for GZdoom to use them.
Save the .ini and launch GZdoom.

Zandronum is alot easier to add mods too than GZdoom.
After you have installed Zandronum browse to where you have it installed and you will find a folder called "skins" drop any external files you want to use like master.wad into this folder and it should autoload them everytime you play Zandronum.

You can also use a frontend launcher like ZDL (zdoom launcher)[zdoom.org] for more complicated setups and profiles.

Hope this all helps?

Dernière modification de Nurdle; 8 sept 2013 à 18h37
Flowmad 9 sept 2013 à 7h19 
@Nurdle OMG IT WORKS!!! O.O I successfully loaded the Master Levels in Brutal Doom with GZdoom, thanks a lot man! :D

Just in case if somebody is still confused, my path looked like this because GZdoom folder was saved in another folder on my desktop:
path=C:\Users\[PC Username]\Desktop\Doom Classic\gzdoom-bin-1-8-02\master.wad
path=C:\Users\[PC Username]\Desktop\Doom Classic\gzdoom-bin-1-8-02\brutalv018a.pk3
If you don't know the path then go to properties in your GZdoom folder and copy the exact path, that worked for me.
Dernière modification de Flowmad; 9 sept 2013 à 7h25
Nurdle 9 sept 2013 à 10h32 
you can try adding other mods too like the high resolution texture pack and psxmusic.
I made a video for youtube a while back using all these mods. All the links are in the description for it.
Flowmad 10 sept 2013 à 4h39 
Oh cool, i gonna check that out! :)
BattleCatalyst 11 déc 2013 à 0h54 
hey guys, im trying to do the same thing. I got about half way through before it not working it seems. I managed to get all the WADS into 1 Master.wad folder. Then I go into the config file and scroll down to doom.autoload. However my config file doesn't have paths listed. They are listed like this






I have added [Master.wad] but when i go to load brutal doom over GZdoom it doesnt show up in my lilst of WADS like the others. I am using GZ Doom 1.8.2 if that helps.
generalbry 21 déc 2013 à 17h18 
If you have GZDoom loaded into Steam, right-click and go to Properties. Where it says target, add at the end of the line "-file" and then add the files you want to load. Put a space between each file, wad, pk3, etc.

e.g. "C:\...path...\gzdoom-bin-1-8-02\gzdoom.exe" -file brutal19.pk3 master.wad

@Nurdle's method works as well, this just another option. I've been playing like this on Windows and haven't had a problem. Just make sure all the files are in the GZDoom folder.
So for the Master Levels specifically, when you start a new game of Doom 2 it should give you an option for which episode, Hell On Earth and Master Levels.

Hope this helps, for anyone still having an issue.
Dernière modification de generalbry; 21 déc 2013 à 17h19
Eddie Fonzarelli 22 déc 2013 à 19h12 
so let me get this str8. I download the "Unofficial Master Levels for Doom 2 Patch" from the following link:


then i put the ~20 masterlevels + any other .wad files into a folder called 'master'.
Then, run the patch.
Then put the Master.wad into the skins folder where the zandronium installation is...
and im good to go?
c@sh 21 juil 2014 à 17h47 
The way how I start a Master Levels of Doom 2 map with GZDoom is just by drag 'n drop both the .WAD file and the brutal19.pk3 at the same time into the gzdoom.exe
For example: drag 'n drop ATTACK.WAD + brutal19.pk3 into gzdoom.exe
Affichage des commentaires 1 à 15 sur 16
< >
Par page : 15 30 50