DOOM 3 > General Discussions > Topic Details
♫ Rainbow Dash ♫ Jul 29, 2013 @ 4:53pm
Doom 3 not running properly. Help please!
This game has been running fine on my computer all this time up until last night when I started having some problems. The framerate is horrible, even in the menu, and in multiplayer, I don't even get one frame per second.

Also, Quake 3 started to ♥♥♥♥ up around the same time. I wonder if it is related to this.

Can anyone help?
Showing 1-8 of 8 comments
< >
2jkaz Jul 30, 2013 @ 7:50am 
...looks like something broke your OpenGL
♫ Rainbow Dash ♫ Aug 1, 2013 @ 8:36pm 
Originally posted by 2jkaz:
...looks like something broke your OpenGL

Anything I can do to fix that?
PunkGuy95 Aug 1, 2013 @ 9:14pm 
I think he was joking. but im having a problem where if i try and run doom 3 after i click on the play button steam crashes help?
2jkaz Aug 3, 2013 @ 4:51pm 
Originally posted by PunkGuy95:
I think he was joking. but im having a problem where if i try and run doom 3 after i click on the play button steam crashes help?:whistle:
i'm not joking i have the same problem with my laptop i have acer ferrari one amd athlon x2 1.2GHz 4g ram 120gb ssd and ati radeon HD3200 and external amilo booster-ati mobility radeon HD3870 ..before i instaled my amilo booster i was on latest ati driver for HD3200 and doom was working properly no problem with opengl but when i conected my external card HD3870 and instaled older driver to get it work with my laptop that driver completely broke my opengl or it didnt istaled properly i tested it with Open gl extension viewer 4.1 and it shows only opengl 1.1 installed by microsoft which is standard and very slow but when are instaled latest drivers from amd for the card opengl should be in version open gl 3.. or 4.3
...not sure if that is his problem too but if he has same problem with quakke3 that sounds to me like good chance there is something wrong with opengl - both games run on it ...i would try reinstal drivers and check open gl with open gl extension viewer... but well it could be anything - virus maybe?
2jkaz Aug 9, 2013 @ 4:51pm 
i'm back on latest driver from ati and opengl now shows version opengl 3.3 for both ati HD cards and doom runs nice without problem but only for few minutes then HD 3870 display driver crashes shortly after launching doom looks like fan is not kicking in and some weird noise comes from card ;o( not sure what is wrong now
Killers300 Aug 26, 2013 @ 8:27pm 
Delete system32
♫ Rainbow Dash ♫ Aug 27, 2013 @ 2:22pm 
Originally posted by Killers300:
Delete system32
This made me laugh!
Spizy Chicken Sep 1, 2013 @ 4:35am 
What OS are you running it on?
Showing 1-8 of 8 comments
< >
Per page: 15 30 50