DOOM 3 > Discussioni generali > Dettagli della discussione
truevalor 18 gen 2013, ore 14:24
Perfected Doom 3 Mod Help
I have modded the non BFG edition of Doom 3 with Perfeced Doom 3 version 6.2.3, I can run the unmodded version of Doom 3 without any issues but when I lauch the modded version the game hangs at the initializing Menu screen. I have windows 7, I don't think that is issue since the vanilla version of the game runs fine. Any Ideas?
Visualizzazione di 1-15 commenti su 20
< >
IceHandz 20 gen 2013, ore 11:12 
What GPU you running?
If ATI, you need to disable Catalyst AI
truevalor 20 gen 2013, ore 12:06 
I'm running a 7870, my CCC version is 12.6 and there is no option that I can find to turn off the Catalyst AI. If you know how please share. Thanks for replying.
chopper [NGC] 20 gen 2013, ore 14:06 
I recommend you also try VelociReal Ultimate mod. It is less heavy on your machine and looks amazing
IceHandz 20 gen 2013, ore 16:40 
Messaggio originale di chopper NGC:
I recommend you also try VelociReal Ultimate mod. It is less heavy on your machine and looks amazing
that mod is meant to be a "fixed" version of sikkmod for people having problems installing sikkmod and the corresponding mods (wulfen, mono, Trent's sound packs, etc.). Perfected mod is almost the same (as it includes all those mods) but it also changes gameplay, adding new monsters and special effects that you don't get in sikkmod.

Messaggio originale di truevalor:
I'm running a 7870, my CCC version is 12.6 and there is no option that I can find to turn off the Catalyst AI. If you know how please share. Thanks for replying.
I found this:

http://forums.steampowered.com/forums/showpost.php?p=33385667&postcount=303
truevalor 21 gen 2013, ore 8:04 
Messaggio originale di IceHandz:
Messaggio originale di chopper NGC:
I recommend you also try VelociReal Ultimate mod. It is less heavy on your machine and looks amazing
that mod is meant to be a "fixed" version of sikkmod for people having problems installing sikkmod and the corresponding mods (wulfen, mono, Trent's sound packs, etc.). Perfected mod is almost the same (as it includes all those mods) but it also changes gameplay, adding new monsters and special effects that you don't get in sikkmod.

Messaggio originale di truevalor:
I'm running a 7870, my CCC version is 12.6 and there is no option that I can find to turn off the Catalyst AI. If you know how please share. Thanks for replying.
I found this:

http://forums.steampowered.com/forums/showpost.php?p=33385667&postcount=303

IceHandz thank you for your help, I appreciate your efforts. I don't know if I want to go through the aggravation to get the mod to function. I think this is my last AMD card. Surprisingly this game does not look bad to me in the game, maybe I'm easily satisfied. I know it would look better with the mod because the picture of Mars at the initializing menu screen is so much more vivid, as you can probably tell, I'm still thinking about it.
IceHandz 21 gen 2013, ore 13:48 
I just randomly ran across that thread 'cause I was trying to learn how to install sikkmod and everything properly, but it could be used for anyone who needs help disabling Catalyst AI. A lot of ATI users have problems with this because ATI refuses to fix their drivers. Their CCC is dysfunctional

And one last thing, if you DO manage to get Perfected to run, just be ready for a very challenging gameplay. Almost anything can kill you in one to two hits...
SirMarth01 21 gen 2013, ore 17:25 
Alternatively...

To disable Catalyst AI:
Method 1:
- Open up AMD Vision Engine Control Center
- Click on Preferences, then Advanced
- Select Gaming on the left, then 3D Application Settings
- Scroll down to Catalyst A.I.
- Set Texture Filtering Quality to "Quality", and uncheck "Enable Surface Format Optimization"

Method 2:
- Open up Windows Explorer
- Type in "%APPDATA%" without quotation marks into the address bar, then replace "roaming" with "Local\ATI\ACE", without quotation marks
- Open up Profiles.xml
- Search for <Feature name="CatalystAI">
- The next line should be something like the following:
<Property name="CatalystAI" value="Enable2"/>
Change "Enable2" or whatever is there to "Disable", making sure to keep it in quotation marks like how "Enable2" is above.

Method 1 has fixed the problems I'd had with another game that uses OpenGL. I've not tried Method 2, but I see no reason why it shouldn't work.
truevalor 22 gen 2013, ore 1:17 
Messaggio originale di SirMarth01:
Alternatively...

To disable Catalyst AI:
Method 1:
- Open up AMD Vision Engine Control Center
- Click on Preferences, then Advanced
- Select Gaming on the left, then 3D Application Settings
- Scroll down to Catalyst A.I.
- Set Texture Filtering Quality to "Quality", and uncheck "Enable Surface Format Optimization"

Method 2:
- Open up Windows Explorer
- Type in "%APPDATA%" without quotation marks into the address bar, then replace "roaming" with "Local\ATI\ACE", without quotation marks
- Open up Profiles.xml
- Search for <Feature name="CatalystAI">
- The next line should be something like the following:
<Property name="CatalystAI" value="Enable2"/>
Change "Enable2" or whatever is there to "Disable", making sure to keep it in quotation marks like how "Enable2" is above.

Method 1 has fixed the problems I'd had with another game that uses OpenGL. I've not tried Method 2, but I see no reason why it shouldn't work.

Thank you. I will give this a try.
truevalor 26 gen 2013, ore 6:31 
Update on progress to run Perfected Mod. I have tried the methods outlined by SirMarth01 and method 1 simply did not work and method 2 when I get to "Local\ATI\ACE" that location contains nothing, there are no profiles to edit.
To Icehandz I followed the guide and installed RadeoPro utility the result is the vanilla game is visually much improved without any framerate impact. Unfortunately the Perfected Mod still locks up.
Thanks to you both for your suggestions. Either way having fun with this game.
IceHandz 26 gen 2013, ore 14:11 
Are the files hidden? You can open it thru Control Panel > Appearance and Personalization > folder options and it should be in there.
truevalor 27 gen 2013, ore 18:12 
Messaggio originale di IceHandz:
Are the files hidden? You can open it thru Control Panel > Appearance and Personalization > folder options and it should be in there.

I assume you are talking about SirMath01 second method. I can access the roaming folder and in it is the ati\ace folder and that is empty and I did make sure to reveal hidden files in the folder options as you suggested. I don't know what he means by replace the roaming file with "local\ati\ace". When I type %appdata% in the search menu it brings me to the roaming file and I cannot replace it but I can access it, and the ati\ace folder has nothing in it. I hope the perfected Doom 3 mod maker will make another update that will work with AMD cards. Certainly gave it my best shot.
SirMarth01 27 gen 2013, ore 18:37 
What I meant was replace:
C:\Users\Example_User\AppData\Roaming
With
C:\Users\Example_User\AppData\local\ati\ace

Replace "Example_User" with your actual account name.
I figured it be easier to work around not knowing your username by using the AppData method, but apparently not. My fault for not making things very clear.
truevalor 28 gen 2013, ore 14:35 
Messaggio originale di SirMarth01:
What I meant was replace:
C:\Users\Example_User\AppData\Roaming
With
C:\Users\Example_User\AppData\local\ati\ace

Replace "Example_User" with your actual account name.
I figured it be easier to work around not knowing your username by using the AppData method, but apparently not. My fault for not making things very clear.

Hi SirMath01, thank you for the clarification and I was able to find profiles.xml and edit the catalyst AI to disabled. Unfortunetly, I cannot get the Perfected Doom 3 mod to work. I don't know if it is possible that the RadeonPro utility is conflicting. When both are edited with the Catalyst AI disabled, the mod does not even function to the initializing menu screen with the much nicer view of Mars. Instead it crashes at the gray screen and locks up and I have to actually Ctrl-Alt-Delete my way out of it. Still I have somethings to try like deleting the profile in the RadeonPro utility and trying again. I can also upgrade my video card drivers, til now I have used the present drivers that I had and just unistalled everything but that graphics driver. At this point I will complete the game in Vanilla mode and if I ever get this mod to work, I will be able to compare. Once again thanks for the advice.
aaronmb3 11 feb 2013, ore 23:01 
Ive got the same problem again. I had it working, but my external hard drive crashed and had to download everything again. I get to the screen and the Pantera song plays for a second, then stops. I noticed that the newest AMD Catalyst changed the Game Settings menu, where it doesnt show a lot of it(particularly the catalyst ai). I reinstalled verson 12(the one before), and its there.
Magus 20 feb 2013, ore 0:06 
Couldn't get the fixes to work, but ATI driver 10.10 has an option to disable the AI. This is what eventually worked for me.
Visualizzazione di 1-15 commenti su 20
< >
Per pagina: 15 30 50
Data di pubblicazione: 18 gen 2013, ore 14:24
Messaggi: 20