DOOM 3 > Γενικές συζητήσεις > Λεπτομέρειες θέματος
truevalor 18 Ιαν, 2013 @ 2:24μμ
Perfected Doom 3 Mod Help
I have modded the non BFG edition of Doom 3 with Perfeced Doom 3 version 6.2.3, I can run the unmodded version of Doom 3 without any issues but when I lauch the modded version the game hangs at the initializing Menu screen. I have windows 7, I don't think that is issue since the vanilla version of the game runs fine. Any Ideas?
Εμφάνιση 1-15 από 19 σχόλια
< >
IceHandz 20 Ιαν, 2013 @ 11:12πμ 
What GPU you running?
If ATI, you need to disable Catalyst AI
truevalor 20 Ιαν, 2013 @ 12:06μμ 
I'm running a 7870, my CCC version is 12.6 and there is no option that I can find to turn off the Catalyst AI. If you know how please share. Thanks for replying.
chopper [NGC] 20 Ιαν, 2013 @ 2:06μμ 
I recommend you also try VelociReal Ultimate mod. It is less heavy on your machine and looks amazing
IceHandz 20 Ιαν, 2013 @ 4:40μμ 
Αναρτήθηκε αρχικά από chopper NGC:
I recommend you also try VelociReal Ultimate mod. It is less heavy on your machine and looks amazing
that mod is meant to be a "fixed" version of sikkmod for people having problems installing sikkmod and the corresponding mods (wulfen, mono, Trent's sound packs, etc.). Perfected mod is almost the same (as it includes all those mods) but it also changes gameplay, adding new monsters and special effects that you don't get in sikkmod.

Αναρτήθηκε αρχικά από truevalor:
I'm running a 7870, my CCC version is 12.6 and there is no option that I can find to turn off the Catalyst AI. If you know how please share. Thanks for replying.
I found this:

http://forums.steampowered.com/forums/showpost.php?p=33385667&postcount=303
truevalor 21 Ιαν, 2013 @ 8:04πμ 
Αναρτήθηκε αρχικά από IceHandz:
Αναρτήθηκε αρχικά από chopper NGC:
I recommend you also try VelociReal Ultimate mod. It is less heavy on your machine and looks amazing
that mod is meant to be a "fixed" version of sikkmod for people having problems installing sikkmod and the corresponding mods (wulfen, mono, Trent's sound packs, etc.). Perfected mod is almost the same (as it includes all those mods) but it also changes gameplay, adding new monsters and special effects that you don't get in sikkmod.

Αναρτήθηκε αρχικά από truevalor:
I'm running a 7870, my CCC version is 12.6 and there is no option that I can find to turn off the Catalyst AI. If you know how please share. Thanks for replying.
I found this:

http://forums.steampowered.com/forums/showpost.php?p=33385667&postcount=303

IceHandz thank you for your help, I appreciate your efforts. I don't know if I want to go through the aggravation to get the mod to function. I think this is my last AMD card. Surprisingly this game does not look bad to me in the game, maybe I'm easily satisfied. I know it would look better with the mod because the picture of Mars at the initializing menu screen is so much more vivid, as you can probably tell, I'm still thinking about it.
IceHandz 21 Ιαν, 2013 @ 1:48μμ 
I just randomly ran across that thread 'cause I was trying to learn how to install sikkmod and everything properly, but it could be used for anyone who needs help disabling Catalyst AI. A lot of ATI users have problems with this because ATI refuses to fix their drivers. Their CCC is dysfunctional

And one last thing, if you DO manage to get Perfected to run, just be ready for a very challenging gameplay. Almost anything can kill you in one to two hits...
SirMarth01 21 Ιαν, 2013 @ 5:25μμ 
Alternatively...

To disable Catalyst AI:
Method 1:
- Open up AMD Vision Engine Control Center
- Click on Preferences, then Advanced
- Select Gaming on the left, then 3D Application Settings
- Scroll down to Catalyst A.I.
- Set Texture Filtering Quality to "Quality", and uncheck "Enable Surface Format Optimization"

Method 2:
- Open up Windows Explorer
- Type in "%APPDATA%" without quotation marks into the address bar, then replace "roaming" with "Local\ATI\ACE", without quotation marks
- Open up Profiles.xml
- Search for <Feature name="CatalystAI">
- The next line should be something like the following:
<Property name="CatalystAI" value="Enable2"/>
Change "Enable2" or whatever is there to "Disable", making sure to keep it in quotation marks like how "Enable2" is above.

Method 1 has fixed the problems I'd had with another game that uses OpenGL. I've not tried Method 2, but I see no reason why it shouldn't work.
truevalor 22 Ιαν, 2013 @ 1:17πμ 
Αναρτήθηκε αρχικά από SirMarth01:
Alternatively...

To disable Catalyst AI:
Method 1:
- Open up AMD Vision Engine Control Center
- Click on Preferences, then Advanced
- Select Gaming on the left, then 3D Application Settings
- Scroll down to Catalyst A.I.
- Set Texture Filtering Quality to "Quality", and uncheck "Enable Surface Format Optimization"

Method 2:
- Open up Windows Explorer
- Type in "%APPDATA%" without quotation marks into the address bar, then replace "roaming" with "Local\ATI\ACE", without quotation marks
- Open up Profiles.xml
- Search for <Feature name="CatalystAI">
- The next line should be something like the following:
<Property name="CatalystAI" value="Enable2"/>
Change "Enable2" or whatever is there to "Disable", making sure to keep it in quotation marks like how "Enable2" is above.

Method 1 has fixed the problems I'd had with another game that uses OpenGL. I've not tried Method 2, but I see no reason why it shouldn't work.

Thank you. I will give this a try.
truevalor 26 Ιαν, 2013 @ 6:31πμ 
Update on progress to run Perfected Mod. I have tried the methods outlined by SirMarth01 and method 1 simply did not work and method 2 when I get to "Local\ATI\ACE" that location contains nothing, there are no profiles to edit.
To Icehandz I followed the guide and installed RadeoPro utility the result is the vanilla game is visually much improved without any framerate impact. Unfortunately the Perfected Mod still locks up.
Thanks to you both for your suggestions. Either way having fun with this game.
IceHandz 26 Ιαν, 2013 @ 2:11μμ 
Are the files hidden? You can open it thru Control Panel > Appearance and Personalization > folder options and it should be in there.
truevalor 27 Ιαν, 2013 @ 6:12μμ 
Αναρτήθηκε αρχικά από IceHandz:
Are the files hidden? You can open it thru Control Panel > Appearance and Personalization > folder options and it should be in there.

I assume you are talking about SirMath01 second method. I can access the roaming folder and in it is the ati\ace folder and that is empty and I did make sure to reveal hidden files in the folder options as you suggested. I don't know what he means by replace the roaming file with "local\ati\ace". When I type %appdata% in the search menu it brings me to the roaming file and I cannot replace it but I can access it, and the ati\ace folder has nothing in it. I hope the perfected Doom 3 mod maker will make another update that will work with AMD cards. Certainly gave it my best shot.
SirMarth01 27 Ιαν, 2013 @ 6:37μμ 
What I meant was replace:
C:\Users\Example_User\AppData\Roaming
With
C:\Users\Example_User\AppData\local\ati\ace

Replace "Example_User" with your actual account name.
I figured it be easier to work around not knowing your username by using the AppData method, but apparently not. My fault for not making things very clear.
truevalor 28 Ιαν, 2013 @ 2:35μμ 
Αναρτήθηκε αρχικά από SirMarth01:
What I meant was replace:
C:\Users\Example_User\AppData\Roaming
With
C:\Users\Example_User\AppData\local\ati\ace

Replace "Example_User" with your actual account name.
I figured it be easier to work around not knowing your username by using the AppData method, but apparently not. My fault for not making things very clear.

Hi SirMath01, thank you for the clarification and I was able to find profiles.xml and edit the catalyst AI to disabled. Unfortunetly, I cannot get the Perfected Doom 3 mod to work. I don't know if it is possible that the RadeonPro utility is conflicting. When both are edited with the Catalyst AI disabled, the mod does not even function to the initializing menu screen with the much nicer view of Mars. Instead it crashes at the gray screen and locks up and I have to actually Ctrl-Alt-Delete my way out of it. Still I have somethings to try like deleting the profile in the RadeonPro utility and trying again. I can also upgrade my video card drivers, til now I have used the present drivers that I had and just unistalled everything but that graphics driver. At this point I will complete the game in Vanilla mode and if I ever get this mod to work, I will be able to compare. Once again thanks for the advice.
aaronmb3 11 Φεβ, 2013 @ 11:01μμ 
Ive got the same problem again. I had it working, but my external hard drive crashed and had to download everything again. I get to the screen and the Pantera song plays for a second, then stops. I noticed that the newest AMD Catalyst changed the Game Settings menu, where it doesnt show a lot of it(particularly the catalyst ai). I reinstalled verson 12(the one before), and its there.
Magus 20 Φεβ, 2013 @ 12:06πμ 
Couldn't get the fixes to work, but ATI driver 10.10 has an option to disable the AI. This is what eventually worked for me.
Εμφάνιση 1-15 από 19 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 18 Ιαν, 2013 @ 2:24μμ
Αναρτήσεις: 20